problem while install IAR plugin into S32DS ARM

cancel
Showing results for 
Search instead for 
Did you mean: 

problem while install IAR plugin into S32DS ARM

Jump to solution
598 Views
steven_zhang
Contributor IV

i tried to install IAR plugin into S32DS but get the following errors ,

steven_zhang_1-1606787528700.png

 

Operation details
Cannot complete the install because one or more required items could not be found.
Software being installed: IAR Common Components 3.0.0.202011101213 (com.iar.common.feature.feature.group 3.0.0.202011101213)
Missing requirement: EMF Ecore 2.13.0.v20170609-0707 (org.eclipse.emf.ecore 2.13.0.v20170609-0707) requires 'bundle org.eclipse.emf.common [2.13.0,3.0.0)' but it could not be found
Cannot satisfy dependency:
From: IAR Common Components 3.0.0.202011101213 (com.iar.common.feature.feature.group 3.0.0.202011101213)
To: org.eclipse.emf.ecore.feature.group [2.13.0,3.0.0)
Cannot satisfy dependency:
From: EMF - Eclipse Modeling Framework Core Runtime 2.13.0.v20170609-0707 (org.eclipse.emf.ecore.feature.group 2.13.0.v20170609-0707)
To: org.eclipse.emf.ecore [2.13.0.v20170609-0707

1 Solution
184 Views
jwkang
Contributor II

I don't know if it solved the problem, but there is no answer, so I answer.
In my opinion, what I used to do in the past seems to have changed some dependencies.
After seeing the missing EMF message, I accessed the Eclipse site and received the version of the emf package that caused the problem and installed it directly from S32DS.

Get the EMF-Updates-2.13 file from http://download.eclipse.org/modeling/emf/emf/builds/release/2.13/index.html

Select the compressed file downloaded from Install New Software -> Add -> Archive and install all EMF related files. So I solved this problem.

I hope you have good results too.

View solution in original post

11 Replies
185 Views
jwkang
Contributor II

I don't know if it solved the problem, but there is no answer, so I answer.
In my opinion, what I used to do in the past seems to have changed some dependencies.
After seeing the missing EMF message, I accessed the Eclipse site and received the version of the emf package that caused the problem and installed it directly from S32DS.

Get the EMF-Updates-2.13 file from http://download.eclipse.org/modeling/emf/emf/builds/release/2.13/index.html

Select the compressed file downloaded from Install New Software -> Add -> Archive and install all EMF related files. So I solved this problem.

I hope you have good results too.

View solution in original post

121 Views
steven_zhang
Contributor IV

it works ,thanks.

Tags (1)
0 Kudos
209 Views
jwkang
Contributor II

0 Kudos
241 Views
jwkang
Contributor II

I have the same issue. Is this a fixed?

0 Kudos
420 Views
stephen_humphre
Contributor II

Was there ever a solution to this?  I am facing the same issue while trying to install S32DS Version 2018.R1 and IAR Embedded Workbench 8.30.1.  They worked great together on my previous laptop, but installing them on my new one using the same installers is producing the issue described above...  (and shown below in the snapshot.)

stephen_humphre_0-1610727426920.png

 

588 Views
steven_zhang
Contributor IV

S32DS for ARM 2018.R1

0 Kudos
583 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

you are probably trying install unsupported IAR version - https://community.nxp.com/t5/S32-Design-Studio/IAR-Plugin-Issue-for-S32K-Design-Studio/m-p/1190948#M... 

 

Jiri

0 Kudos
574 Views
steven_zhang
Contributor IV

I tried the S32DS 2.2 get the same error.

0 Kudos
537 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

here is step by step guide how to install lAR plugin - https://community.nxp.com/t5/S32-Design-Studio-Knowledge-Base/HOWTO-Install-IAR-Eclipse-plug-in-into... 

 

Hope it helps. 

Jiri 

0 Kudos
594 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

same question as on the other IAR thread - what is your S3DS Version?

 

BR, 

Jiri 

0 Kudos
587 Views
steven_zhang
Contributor IV

it‘s S32DS FOR ARM 2018.R1.

0 Kudos