Chromium on IMX8

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Chromium on IMX8

Jump to solution
5,665 Views
Giacomo_
Contributor II

Hello community,
I am trying to compile the chromium-ozone-wayland based on Yocto hardknott (imx-5.10.35-2.0.0.xml) on IMX8MQEVK board, but the compilation fails with the error:

| Package dri was not found in the pkg-config search path.
| Perhaps you should add the directory containing `dri.pc'
| to the PKG_CONFIG_PATH environment variable
| No package 'dri' found
|
| See //content/gpu/BUILD.gn:141:18: which caused the file to be included.
| configs += [ "//build/config/linux/dri" ]
| ^-------------------------
| WARNING: exit code 1 from a shell command.

In my previous version (Yocto Warrior) I was able to fix it by adding this dependency:

DEPENDS += " mesa "

but this trick no longer works, has anyone successfully compiled chromium?
I know... There is no support for Chromium, I am just asking.

 

 

Labels (2)
Tags (1)
0 Kudos
1 Solution
5,626 Views
Jeroen_H
Contributor III

Just to let you know, I'm trying to buildby using this patch right now:

https://github.com/OSSystems/meta-browser/issues/528

Seach for "0013-Only-DRI-for-x11.txt" and adapt to your code version.

But, it takes a while to build Chromium, I'll post my finding later.

Hopefully DRI isn't needed on iMX8 and Wayland.

Cheers,

Jeroen.

View solution in original post

11 Replies
5,589 Views
Jeroen_H
Contributor III

Hi!

Thanks for pointing us out to the document. I've already gone through these steps.

Unfortunately, adding mesa to the depends, and building seperately still produced errors during do_configure().

Kind regards,

Jeroen.

0 Kudos
5,607 Views
Giacomo_
Contributor II

Backporting? Yes, I can evaluate this too, thanks.

0 Kudos
5,646 Views
Giacomo_
Contributor II

here you are my bbappend:

chromium-ozone-wayland_83.0.4103.116.bbappend

it contains only one line:

DEPENDS += " mesa "

0 Kudos
5,638 Views
Jeroen_H
Contributor III

Okay, thanks, I'll have a look

0 Kudos
5,627 Views
Jeroen_H
Contributor III

Just to let you know, I'm trying to buildby using this patch right now:

https://github.com/OSSystems/meta-browser/issues/528

Seach for "0013-Only-DRI-for-x11.txt" and adapt to your code version.

But, it takes a while to build Chromium, I'll post my finding later.

Hopefully DRI isn't needed on iMX8 and Wayland.

Cheers,

Jeroen.

5,608 Views
Giacomo_
Contributor II

Yes please, let me know the outcome.

0 Kudos
5,590 Views
Jeroen_H
Contributor III

Hi,

Building succeeded, I have chromium (83.0.4103.116) running now on iMX8M Mini, weston-wayland, and using the GPU of the iMX.

I'm using Zeus btw.

Performance looks good.

Still doing some testing, but I think you can take it from here

Jeroen.

0 Kudos
5,061 Views
r_trivedi123
Contributor IV

Hi Jeroen,
Can you share,

Which BSP you used ?
How did you build (for wayland running on GPU ) ? , basically build step doc or pointers.
Any performance statistics or issues you found ?

Appreciate your guidance.

--
Thanks
Rutvij

0 Kudos
5,554 Views
Giacomo_
Contributor II

Kudos to Jeroen (not the button only).

This is the way to go.

Thank you for helping!

0 Kudos
5,651 Views
Jeroen_H
Contributor III

Hi,

I have the same issue (iMX8M Mini, using Zeus 5.4.47) , no solution found yet.
Can you tell me the exact version of Yocto Warrior (or actually the version of Chromium) you've been using previously?

Just wanted to have a look at the differences....

0 Kudos