Bitbake recipe error using procedure in IMXLXYOCTOUG.pdf and IMX6YOCTOPATCHRN.pdf

cancel
Showing results for 
Search instead for 
Did you mean: 

Bitbake recipe error using procedure in IMXLXYOCTOUG.pdf and IMX6YOCTOPATCHRN.pdf

Jump to solution
7,393 Views
ScottKerstein
Contributor III

Hello,

 

I'm seeing an Bitbake error using the procedure outlined in the above documents attempting to Bitbake fsl-image-gui for SABRE-SDP

.

.

-Werror -isystem/home/scott/fsl-release-bsp/build-sabre-fsl-image-gui/tmp/sysroots/x86_64-linux/usr/include -O2 -pipe -c /home/scott/fsl-release-bsp/build-sabre-fsl-image-gui/tmp/work/x86_64-linux/binutils-native/2.23.2-r4/binutils-2.23.2/bfd/linker.c -o linker.o

| cc1: all warnings being treated as errors

| Makefile:1579: recipe for target 'opncls.lo' failed

| make[4]: *** [opncls.lo] Error 1

| make[4]: *** Waiting for unfinished jobs....

.

.

| ERROR: Function failed: do_compile (log file is located at /home/scott/fsl-release-bsp/build-sabre-fsl-image-gui/tmp/work/x86_64-linux/binutils-native/2.23.2-r4/temp/log.do_compile.3999)

ERROR: Task 1062 (virtual:native:/home/scott/fsl-release-bsp/sources/poky/meta/recipes-devtools/binutils/binutils_2.23.2.bb, do_compile) failed with exit code '1'

NOTE: Tasks Summary: Attempted 512 tasks of which 316 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

 

Summary: 1 task failed:

  virtual:native:/home/scott/fsl-release-bsp/sources/poky/meta/recipes-devtools/binutils/binutils_2.23.2.bb, do_compile

Summary: There was 1 WARNING message shown.

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

scott@ubuntu:~/fsl-release-bsp/build-sabre-fsl-image-gui$

 

The log file is attached for further viewing.  I believe that I have installed all of the necessary host packages per the documents, and the Yocto Project QSG.   I have checked for updates and none needed.

 

What is missing?

 

Thanks in advance,

Scott

Original Attachment has been moved to: log.do_compile.3999.zip

Labels (3)
1 Solution
3,724 Views
CommunityBot
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!

View solution in original post

0 Kudos
9 Replies
3,725 Views
CommunityBot
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!
0 Kudos
3,728 Views
gabriele74
Contributor II

The problem is that in new GCC4.9.2 used in Ubuntu has enabled -Wunused-value for -Wall and together with -Werror, it's turned into a compilation error.

Adding '--disable-werror' to the 'EXTRA_OECONF_class-native' variable in the binutils recipe:

poky/meta/recipes-devtools/binutils/binutils_2.23.2.bb

i.e.:

EXTRA_OECONF_class-native = "--enable-targets=all --enable-64-bit-bfd --enable-install-libbfd --disable-werror "

solves the problem for me on Ubuntu Vivid 15.04

Or better create a .bbappend in your layer and add it there.

Hope it helps, bye.

3,728 Views
ScottKerstein
Contributor III

Sorry for my late reply on this.  Schedule got turned around a few times.

My server would be either SABRE-SDP or Nitrogen6x board and the host would be Ubuntu 14.10.  Working on this soon.

0 Kudos
3,728 Views
smspatrick
Contributor III

Hi Scott,

got exactly the same issue, it's about

opncls.lo

the build of it failed with:

...

| In file included from /home/patrick/Uni/fsl-arm-yocto-bsp/build/tmp/work/x86_64-linux/binutils-native/2.23.2-r4/binutils-2.23.2/bfd/opncls.c:26:0:

| /home/patrick/Uni/fsl-arm-yocto-bsp/build/tmp/work/x86_64-linux/binutils-native/2.23.2-r4/binutils-2.23.2/bfd/opncls.c: In function 'bfd_fopen':

| ./bfd.h:529:65: error: right-hand operand of comma expression has no effect [-Werror=unused-value]

|  #define bfd_set_cacheable(abfd,bool) (((abfd)->cacheable = bool), TRUE)

|                                                                  ^

...

For the answer of Yuri:

The Host setup is exactly as mentioned in "Freescale_Yocto_Project_User's_Guide.pdf" (all packages installed, repo runs), and finally the minimal configuration got the same issue.

Found that a similar issue is described and solved in Debians sdcc package: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=752972

Any other ideas?

0 Kudos
3,728 Views
Yuri
NXP TechSupport
NXP TechSupport
0 Kudos
3,728 Views
bricdesigns
Contributor II

I had the same issue trying to build 3.10.17 on a 14.10 ubuntu machine.  Going to 3.10.53, I no longer see the issue (although now the build is crashing because it can't download fsl-gpu-sdk-2.0.bin).

0 Kudos
3,728 Views
gusarambula
NXP TechSupport
NXP TechSupport

Thanks for posting this question separately. I'm adding the link here as reference:

Unable to download fsl-gpu-sdk-2.0.bin

0 Kudos
3,728 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Patrick,

What host are you using? I'm also trying to figure our a similar issue on a Ubuntu 14.04 host and while this host is not the recommended the error doesn't seems related but I wanted to check anyways. If I find any more information regarding this I'll also post it here.

Please let me know if you have any findings as well!

0 Kudos
3,728 Views
Yuri
NXP TechSupport
NXP TechSupport

  Please look at my comments below.


1.

Please check recommendations of section 3 (Host Setup) in "Freescale_Yocto_Project_User's_Guide.pdf".


2.

  First, please try to build minimal configuration.


Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos