AnsweredAssumed Answered

Unable to program MK22FX512AVLQ12 controller

Question asked by Gaurav More on Nov 27, 2019
Latest reply on Dec 8, 2019 by Kerry Zhou

Hi ,

 

I am using MK22FX512AVLQ12 controller in one of my product. I have made the development board for the same. But after assembly I am not able to programm the controller. i am using PE MICRO FX debugger. Before going for the development board design I first evaluated  FREEDOM K22F evaluation board. 

 

I used MCU Xpresso for the evaluation and PE MICRO (Rev B, D, FX Rev D) All these wer able to programme. Also i used LPC11U68 Eval board Debugger for programming . I was able to programm and debug using all these debuger.

But now when i made the development board of MK22FX512AVLQ12 controller and tried to programme then it is showing error.

 

I have attached the schematic and also made the modification in the hardware like pull up to EZ_CS pin as per the input from one of the forum. 

 

I am facing this issue from last 3-4 days but still no sucess, please check the schematic and suggest the solution for the same.

jeremyzhouCon Verse

 

Thanks 

Gaurav More 

Attachments

Outcomes