AnsweredAssumed Answered

Porocessor Expert: ERROR: Not possible to run ...

Question asked by marcinmazur on Mar 8, 2016
Latest reply on Mar 14, 2016 by Marek Trmac

Hi.

Finally i got KDS installed and updated to newest version 3.1.0, PEx 3.0.2b, KSDS 1.3.0.

 

I'm trying to start new simple project with PEx for processor: mkl03z8vfg4

 

Every time I add one of those components:

 

Component: i2cCom1 of type fsl_i2c<br/>Description: Kinetis SDK

Peripheral Driver (i2c)

Repository: KSDK 1.3.0

 

Component: spiCom1 of type fsl_spi<br/>Description: Kinetis SDK

Peripheral Driver (spi)

Repository: KSDK 1.3.0

 

Component: adConv1 of type fsl_adc16<br/>Description: Kinetis SDK

Peripheral Driver (adc16)

Repository: KSDK 1.3.0

 

Component: voltageRef1 of type fsl_vref<br/>Description: Kinetis SDK

Peripheral Driver (vref)

Repository: KSDK 1.3.0

 

and press the Generate PEx code button (Cant remember the right name) I get a following ERROR:

 

ERROR: Not possible to run: Drivers\Kinetis\printConfigs.js.javax.script.ScriptException:
sun.org.mozilla.javascript.internal.EcmaError: TypeError: Cannot find
function getEditorData in object
com.processorexpert.core.service.api.internal.PExInspectorIntegerItemAPI@404e93.
(<Unknown source>#89) in <Unknown source> at line number 89

 

Components are configured,  and I can not see any errors.

Other components added (and dependent of those) are working fine.

 

What i'm doing wrong ?

Outcomes