S32 Design Studio Activation issue

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

S32 Design Studio Activation issue

4,972 Views
christopher_lon
Contributor II

Every so often this error will occur, and cause me to reinstall the design studio. I have activated it the studio half a dozen times in the last 6 months.... The license is valid, something else is occurring. Offline activation doesn't work either.

Any suggestions, I don't want to continue reinstalling 

Tags (3)
23 Replies

4,144 Views
francesco_matti
Contributor II

Hello Mike Doidge,

the issue is appeared again.

Attached the logs.

best regards

0 Kudos
Reply

4,143 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it‌,

Is it possible for you to migrate to the latest release? S32 Design Studio for ARM 2.2 (Windows/Linux) released! 

Next time this issue occurs, instead of reinstalling the S32 Design Studio, could you try the solution detailed within Troubleshooting: Installer rolls back immediately following activation code entry 

In addition, we have some instructions to use licfix.zip. https://community.nxp.com/docs/DOC-334344 

Please let us know if any of these solutions work, as we are so far unable to reproduce this issue on our end.

Best Regards,

Mike

0 Kudos
Reply

4,143 Views
francesco_matti
Contributor II

Hello mikedoidge

for the moment i have not reinstall the S32 Desgin Studio.

I have deleted the folder  'C:\ProgramData\FLEXNet' but the error is still here.

0 Kudos
Reply

4,143 Views
mikedoidge
NXP Employee
NXP Employee

Hi francesco.mattioli@efitechnology.it‌,

We are now suspecting, as christopher.long@magna.com‌ suggested, that this could be due to some conflict between two tools, each using flexera for licensing. Perhaps the versions of flexnet is different and this creates a problem. Do you have other applications installed which use flexera licensing?

Could you please describe the issue in more detail? At what point does the error message appear? Does it prevent you from using the S32 Design Studio? Does reinstalling the S32 Design Studio correct the issue (even if only temporarily)?

Best Regards,

Mike

4,143 Views
francesco_matti
Contributor II

Hi mikedoidge‌,

Could you please describe the issue in more detail? yes

At what point does the error message appear? i open the S32, and immediately after this is the messagge pastedImage_2.png

if i click "Activate "

pastedImage_6.png

if i put the code activation

pastedImage_7.png

Does it prevent you from using the S32 Design Studio? yes

Does reinstalling the S32 Design Studio correct the issue (even if only temporarily)? yes, only temporarily

I will check for Flexera: i have also the S32 studio for power architecture

0 Kudos
Reply

4,144 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it‌,

We have one more request of you. Could you please check the following?

In Windows start Explorer, right-click on Computer, choose Manage, click on “Services and Applications”, and choose Services.

Then find both “FlexNet Licensing Service” and “FlexNet Licensing Service 64” and open their “Path to executable”, something like:

"C:\Program Files (x86)\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService.exe"

"C:\Program Files\Common Files\Macrovision Shared\FlexNet Publisher\FNPLicensingService64.exe"

For them check the Details tab.

 

If either of two is not “Product version 11.13.0.2 build 16702” it would be helpful to know that – is it newer or older version, 32/64-bit or both are different.

pastedImage_1.pngpastedImage_2.png

This will help us greatly in diagnosing your issue.

Thanks,

Mike

0 Kudos
Reply

4,144 Views
francesco_matti
Contributor II

Hello mikedoidge‌,

pastedImage_1.png

pastedImage_2.png

0 Kudos
Reply

4,144 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it‌,

We have been able to reproduce the issue. We believe our method represents your environment closely, but it is impossible to be sure. Here are our recommendations for resolving this issue:

  1. We recommend to avoid using other tools protected with FlexNet Publisher on the same computer with S32DS.
    When a user installs that other SW, FlexNet protection services become incompatible with S32DS and S32DS licenses may be wiped from TS.
  2. In order to execute S32DS after other SW used, user should 1) repair FlexNet services to compatible version and 2) start S32DS and if needed enter an activation code.
    1. In order to repair, go to S32DS\cll\i86\ and run:
      cllSvrUtility.exe -installService DummyName
  3. Another way is to download correct (to S32DS) executables with services (attached) and replace them in the system.

We hope these recommendations will help you to resolve the issues. Please reply with your results.

Best Regards,

Mike

0 Kudos
Reply

4,143 Views
francesco_matti
Contributor II

Hello @Mike Doidge,

1. We recommend to avoid using other tools protected with FlexNet Publisher on the same computer with S32DS.
When a user installs that other SW, FlexNet protection services become incompatible with S32DS and S32DS licenses may be wiped from TS. -> How can i control in my computer?

2. In order to execute S32DS after other SW used, user should 1) repair FlexNet services to compatible version and 2) start S32DS and if needed enter an activation code.

  1. In order to repair, go to S32DS\cll\i86\ and run:
    cllSvrUtility.exe -installService DummyName -> i cannot find this in my computer: can you write the exactly position?

3. Another way is to download correct (to S32DS) executables with services (attached) and replace them in the system.

i have downloaded the attached and i have replaced in the system...but nothing change.

0 Kudos
Reply

4,143 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it‌,

For #2, see the image for the location of this file.
pastedImage_1.png

Let us know if this works.

Best Regards,

Mike

0 Kudos
Reply

4,143 Views
francesco_matti
Contributor II

Hello mikedoidge‌,

but the location is only for the newest version? i still have the 2018 and the location is not exist.

best regards

Francesco

0 Kudos
Reply

4,138 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it,

We have not implemented anything specifically for this issue in the latest releases, however, we have implemented many improvements and bug fixes. It is possible that the issue will not be present for you with the latest version, but we cannot guarantee it. If you prefer, it is possible to have both versions installed concurrently. They will install to different directories since the version is part of the installation folder name. Perhaps by installing the new version, the old version will cease to experience the issue. It is worth a try, is it not?

Ideally, we would prefer you migrate to the latest version, however, we understand that some users will be restricted by their quality process to lock to a release and not upgrade.

Best Regards,

Mike

0 Kudos
Reply

4,139 Views
francesco_matti
Contributor II

Hello mikedoidge‌,

thanks for the help.

At the moment i have unistalled the old version for Arm, and installed the newer....i will let you know if the issue reappears.

another few questions:

  1. Are there some contraindications to have ARM and Power IDE on the same PC ??
  2. Are there some guideline to update a project from Arm 2.1 to 2.2 ?

best regards

Francesco

0 Kudos
Reply

4,139 Views
mikedoidge
NXP Employee
NXP Employee

Hi francesco.mattioli@efitechnology.it‌,

I have both the ARM and Power IDE tools installed to my PC now. There should be no issues with this configuration. As I previously noted, you could even have multiple versions of the same IDE tool installed without issue.

The only step you need to take to update your project for the new version of the Arm IDE is to create a new workspace (create it with the new IDE) and then copy your project to this new workspace. The workspace will hold information which is specific to the version of Eclipse used in the previous IDE version and this will avoid issues related to incompatibilities between old workspaces and new versions of Eclipse.

If you have projects which use the S32 SDK, then you should post any issues you experience in the community for the SDK: https://community.nxp.com/community/s32/s32sdk 

Hope that helps,

Mike

0 Kudos
Reply

4,143 Views
francesco_matti
Contributor II

Hello mikedoidge‌,

i have another question:

With the latest version of S32 Studio, S32 Design Studio for ARM 2.2  and S32 Design Studio for Power Architecture® v2.1 , the issue is fixed??

best regards

Francesco

0 Kudos
Reply

4,142 Views
mikedoidge
NXP Employee
NXP Employee

Hello francesco.mattioli@efitechnology.it‌ and christopher.long@magna.com‌,

Are you currently sharing your S32 Design Studio activation code with other users or have you installed S32 Design Studio in multiple locations using the same activation code?

Is S32 Design Studio the only application which is affected? If you have other applications with Flexera-based licensing, they continue to operate normally?

Are you aware of any change which coincides with the start of this issue? A new application is installed? Windows update?

Thanks,

Mike

0 Kudos
Reply

4,142 Views
francesco_matti
Contributor II

Hi mikedoidge‌,

Are you currently sharing your S32 Design Studio activation code with other users or have you installed S32 Design Studio in multiple locations using the same activation code? NO

Is S32 Design Studio the only application which is affected? If you have other applications with Flexera-based licensing, they continue to operate normally? S32 Studio: ARM and Power both

Are you aware of any change which coincides with the start of this issue? A new application is installed? Windows update? i don't know

My question is: how can i found in my pc, the other applications that use Flexera???

best regards

0 Kudos
Reply

4,145 Views
christopher_lon
Contributor II

Reinstalling does fix the issue, but not the root cause (can and will happen again). 

I later had the same issue a few more times. Long story short I believe the the root cause is related to the licensing software (flexera or something like the). I say this because I was installing and using vectorcast on the same computer. VectorCast also uses flexera. Something was causing conflict. I don't remember exactly how i resolved the issue but it was something about flexera. 

What i dont understand is why S32DS even uses any sort of licensing software like flexera when its a free download. 

0 Kudos
Reply

4,145 Views
mikedoidge
NXP Employee
NXP Employee

Hello christopher.long@magna.com‌,

Which version of S32 Design Studio are you using?

Could you provide the log files? 

For ex. C:\NXP\S32DS_Power_v2.1\_S32 Design Studio for Power Architecture Version 2.1_installation\Logs

and

C:\Users\...\workspaceS32DS.Power.2.1\.metadata

Thanks,

Mike

0 Kudos
Reply

4,145 Views
francesco_matti
Contributor II

Hello Mike Doidge,

i have the same issue...can you help me?

0 Kudos
Reply