S32 Design Studio for ARM 2.2 (Windows/Linux) released!

cancel
Showing results for 
Search instead for 
Did you mean: 

S32 Design Studio for ARM 2.2 (Windows/Linux) released!

S32 Design Studio for ARM 2.2 (Windows/Linux) released!

 

 

 

nxp.png 

Product Release Announcement

Automotive Processing

S32 Design Studio for ARM 2.2

S32DS_Logo_official_2016_scaled.png

 

 

 

 

January 31, 2020

 

The Automotive Processing's Embedded Tools Team at NXP Semiconductors is pleased to announce the release of the S32 Design Studio for Arm® v2.2.  Here are some of its major features:

  • GNU Bare-Metal Targeted Tools for Arm® 32-bit Embedded Processors (GCC version 6.3.120170509, revision g7fea41d)
  • GNU Tools for Arm® Embedded Processors (Launchpad) (GCC version 4.9.3 20150529,revision 227977)
  • Libraries: NewLib, NewLib Nano, EWL, and EWL Nano
  • Semihosting for Arm® 32-bit Bare-Metal Targeted toolchain
  • MSYS2 32bit version 1.0.0
  • GDB 7.12.1 with Python support
  • The wizards for creating application, library projects and projects from project examples
  • The S32DS Extensions and Updates tool
  • Support for importing projects from CodeWarrior for MCU v.10.6 and Kinetis Design Studio
  • Support for importing MCAL configuration to a custom SDK
  • IAR v7.x and v8.11.2 compiler support
  • Green Hills compiler support
  • SEGGER J-Link (with SEGGER GDB Server)
  • iSystem, Lauterbach and IAR debuggers support
  • PEMicro debugger support (P&E Multilink/Cyclone/OpenSDA)
  • Kernel Aware debugging for FreeRTOS, OSEK
  • MQX 4.2 for MAC57D54H
  • EmbSys Registers view support
  • FreeMASTER Serial Communication Driver v2.0
  • Sample Drivers for KEA family (Evaluation grade)
  • Integrated S32SDK RTM 3.0.2
  • Integrated AMMCLIB SDKs 1.1.18
  • The Getting Started page

 

NOTE Support for S32V234 was moved to S32 Design Studio for S32 Platform 3.x and not included into S32 Design Studio for ARM anymore.

The complete S32 Design Studio for ARM 2.2 release notes are attached below.

 

Installation Notes

Please visit the S32 Design Studio for ARM product page - download section or direct link to download the installer.

pastedImage_1.png

The installer requires the NEW Activation ID to be entered during the installation.

You should receive an email that includes your Activation ID after starting the download.

pastedImage_88.png

 

Technical Support

S32 Design Studio issues are tracked through the S32 Design Studio Public NXP Community space:

https://community.nxp.com/community/s32/s32dsS32 Design Studio

 

 

Labels (1)
Attachments
Comments

Hi Mike,

I'm a bit confused.

  1. This is a new release from ~January 2020, correct? The date above shows February 6, 2017
  2.  Is this version 2.2 a successor to the V2018.R1? Why do we have such strange versioning?

W.

Hello Q_man‌,

Thank you for pointing out the error in the date. This was a copy/paste error. I have now corrected it.

As for the versioning, I apologize for this, we know it is confusing. We expect the current format to remain for now as it is standardized for NXP.

Best Regards,

Mike

The installer does not seem to accept a console installation method

My OS is Ubuntu 20.04 running the Java virtual machine as recommended by the Release Notes. The GUI installation kept hanging on the splash, when the progress bar was very near the end. This is why I tried console mode

The following is an output from my shell

family@family-desktop:~/Downloads$ ./S32DS_ARM_Linux_v2.2.bin -i console
Preparing to install
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...


=======================================================

Installer User Interface Mode Not Supported

The installer cannot run in this UI mode. To specify the interface mode, use the -i command-line option, followed by the UI mode identifier. The valid UI modes identifiers are GUI, Console, and Silent.

=======================================================

I have also tried the switch -i Console too

Is there any other way of installing the software?

Hello adam.hamilton@seeingmachines.com‌,

We have tried a similar scenario on our end. We used fresh Ubuntu 20.04LTS image, then Update/Upgrade  and then followed the steps in the Installation guide for Linux host. Everything works out of box.

Could you please check if an installation log file was created? Perhaps it would contain some clue. Look for a .log file in: \NXP\S32DS_ARM_v2.2\_S32 Design Studio for ARM Version 2.2_installation\Logs\

Best Regards,

Mike

Hi Mike
Thanks but the installation log directory is a windows path. Where would this be located in a Linux Distro?
Also going by previous installations where it installs in <home>/NXP/S32DS.... this is not created until you choose an install location, which I never got to.
Now, I eventually figured out the problem and it might be worthwhile to note somewhere that you can only have one version of Java installed.
For me, I had both openjdk-8 and open-jdk11
When I originally had open-jdk11, the installer had refused to run at all.
I had to then install openjdk-8 and use update-alternative to pick the 8 over the 11 and then it worked, up to the point where it stalled on the splash screen
When I removed open-jdk-11 from my system it started working and I can now install the software.
But I guess one question remains though, why does the installer refuse to work with a later version of the JRE?
Cheers
Version history
Revision #:
1 of 1
Last update:
‎02-04-2020 01:27 PM
Updated by: