Init_I2S error messages

cancel
Showing results for 
Search instead for 
Did you mean: 

Init_I2S error messages

Jump to solution
232 Views
robotjosh
Contributor IV

I get errors when I try to use the I2S master clock in the Init_I2S bean.  When I set the serial master clock pin I get this error :

DescriptionResourcePathLocationType
Direction Output cannot be set. Supported directions are: [Input/Output] (Pin)Main_K22I2S0/PinProcessor Expert Problem

I've tried changing that pin to the other available master clock pin and get the same error.  If I make it an input instead of an output I get a similar error that "Direction Input cannot be set."

I attached a screenshot of the problem.i2s_error.png

Tags (1)
1 Solution
128 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hi Josh,

I have send you the method to your email , have you receive it ?

The Processor Expert team engineer saids :

"

- In the component inspector of the Init_I2S component, open the context menu of the Pin property in the Serial Master clock pin group and select "Enable Automatic". The selection of the pin is cleared and an error is repoted (no pin selected).

pastedImage_0.png
- Open Component Inspector of the PinSettings, select Collapsed View Mode, I2S tab and select the required pin in the I2S0 > MCLK - Master clock property. The pin is selected and properly routed and the selected pin is also displayed in the Pin property in the Init_I2S component.

pastedImage_1.png

"

Best Regards,

Alice

------------------------------------------------------------------------------------------

If this post answers your question, please click the Correct Answer button.

-----------------------------------------------------------------------------------

If this post help your question, please click the helpful Answer button.

View solution in original post

2 Replies
129 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hi Josh,

I have send you the method to your email , have you receive it ?

The Processor Expert team engineer saids :

"

- In the component inspector of the Init_I2S component, open the context menu of the Pin property in the Serial Master clock pin group and select "Enable Automatic". The selection of the pin is cleared and an error is repoted (no pin selected).

pastedImage_0.png
- Open Component Inspector of the PinSettings, select Collapsed View Mode, I2S tab and select the required pin in the I2S0 > MCLK - Master clock property. The pin is selected and properly routed and the selected pin is also displayed in the Pin property in the Init_I2S component.

pastedImage_1.png

"

Best Regards,

Alice

------------------------------------------------------------------------------------------

If this post answers your question, please click the Correct Answer button.

-----------------------------------------------------------------------------------

If this post help your question, please click the helpful Answer button.

View solution in original post

128 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Josh,

I will reply you on the CRM , i have create a SR for you , SR# 1-3731045071 , 。

And you will receive my message by your email .

Best Regards,

Alice

------------------------------------------------------------------------------------------

If this post answers your question, please click the Correct Answer button.

-----------------------------------------------------------------------------------

If this post help your question, please click the helpful Answer button.

0 Kudos