Bebugging Problem in LPCXpresso, using NHS3152

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bebugging Problem in LPCXpresso, using NHS3152

Jump to solution
847 Views
Sebastiano
Contributor I

Hi,

I am using the NHS3152 kit linked to a PC with Windows 10 and LPCXpresso V8.2.2_650 installed. I have installed the plugin "NHS3152 SDK-v12.5" (release_mra_2_12_5).

When trying to debug the example project "app_demo_dp_blinky", I get message "Errors exist in the active configuration of project app_demo_dp_blinky. Proceed with launch?". Then I select the button "Proceed" and I get the following error:LPCXpresso_error_message.png

How can I solve the problem?

Another question: what IDE works with NHS3152 with LPC-Link2 board: LPCXpresso or MCUXpresso? I am a bit confused ... (on the web page "NHS3152 General Starter Kit" it suggest LPCXpresso, but in the web page "LPCXpresso IDE v8.2.2" it reccomend MCUXpresso for LPC Cortex-M based microcontrollers)

Thanks,

Sebastiano

Labels (1)
0 Kudos
1 Solution
823 Views
patrickgeens
NXP Apps Support
NXP Apps Support

Hello Sebastiano,

 

1) NHS SDK version12.5 moved to MCUXpresso and is unfortunately not LPCXpresso compatible.

Use MCUXpresso version 10.2.1 as this version is compatible with the NHS3xxx plugin..

https://www.nxp.com/products/rfid-nfc/nfc-hf/ntag-smartsensor/ntag-smartsensor-with-temperature-sens...

patrickgeens_0-1675669744914.png

patrickgeens_1-1675669827376.png

When switching to MCUXpresso I recommend starting a new blank workspace and do a fresh import of the SDK example(s).

 

2) MCUXpresso can use LPC-LINK2 as a flashing and debugging interface.

 

Kind regards,

Patrick

View solution in original post

0 Kudos
3 Replies
812 Views
Sebastiano
Contributor I

Ok, thank you Patrick!

Another question... I also have a PC with Windows 11: may MCUXpresso 10.2.1 run also on a PC with Windows 11 installed?

Best regards,

Sebastiano

0 Kudos
791 Views
patrickgeens
NXP Apps Support
NXP Apps Support

Hi Sebastiano,

 

Win11 is supported.

 

Kind regards,

Patrick

0 Kudos
824 Views
patrickgeens
NXP Apps Support
NXP Apps Support

Hello Sebastiano,

 

1) NHS SDK version12.5 moved to MCUXpresso and is unfortunately not LPCXpresso compatible.

Use MCUXpresso version 10.2.1 as this version is compatible with the NHS3xxx plugin..

https://www.nxp.com/products/rfid-nfc/nfc-hf/ntag-smartsensor/ntag-smartsensor-with-temperature-sens...

patrickgeens_0-1675669744914.png

patrickgeens_1-1675669827376.png

When switching to MCUXpresso I recommend starting a new blank workspace and do a fresh import of the SDK example(s).

 

2) MCUXpresso can use LPC-LINK2 as a flashing and debugging interface.

 

Kind regards,

Patrick

0 Kudos