Working With GUI Flash Tool MCUXpresso

cancel
Showing results for 
Search instead for 
Did you mean: 

Working With GUI Flash Tool MCUXpresso

Jump to solution
2,494 Views
kaarthick
Contributor II

Hai,

I am working with MCUXpresso. I need to flash s19 file with GUI Flash tool. I am getting error like below:

P&E Interface detected - Flash Version 9.93
Device is NXP_K1x_K10DN512M10.
Mode is In-Circuit Debug.
(C)opyright 2012, P&E Microcomputer Systems, Inc. (www.pemicro.com)
API version is 101
Creating kernel driver for freertos
Server 1 running on 127.0.0.1:7224
Server 2 running on 127.0.0.1:7226
Server 3 running on 127.0.0.1:7228
Server 4 running on 127.0.0.1:7230
Server 5 running on 127.0.0.1:7232
Server 6 running on 127.0.0.1:7234
Server 7 running on 127.0.0.1:7236
Server 8 running on 127.0.0.1:7238
Server 9 running on 127.0.0.1:7240
Server 10 running on 127.0.0.1:7242
Warning: No data was programmed in FLASH
All Servers Running
Target Disconnected.

Support me soon. Is there any external Flash Software tool available for MK10 Series controller with PE Micro Debugger?

Tags (1)
1 Solution
1,675 Views
prashant_humbre
Contributor II

Hey hi Karthik, 

are you still facing the same issue?

I was also facing this issue while flashing .axf from MCUXpresso IDE.

I tried through many ways and found the actual problem!

It was because of spacing in the path of the project! (Folder name with spaces)

To check whether you have the same problem or not, just copy your .axf to somewhere else where there is no spacing in the path and flash.

It worked for me!

Regards,

Prashant Humbre

View solution in original post

15 Replies
1,675 Views
lpcxpresso_supp
NXP Employee
NXP Employee

This issue has been reported to P&E and we will be working with them to resolve in a future MCUXpresso IDE release.

Regards,

MCUXpresso IDE Support

1,676 Views
prashant_humbre
Contributor II

Hey hi Karthik, 

are you still facing the same issue?

I was also facing this issue while flashing .axf from MCUXpresso IDE.

I tried through many ways and found the actual problem!

It was because of spacing in the path of the project! (Folder name with spaces)

To check whether you have the same problem or not, just copy your .axf to somewhere else where there is no spacing in the path and flash.

It worked for me!

Regards,

Prashant Humbre

View solution in original post

1,675 Views
matute
Contributor III

Thank you!!! It helps me to solve this problem!

0 Kudos
1,675 Views
kaarthick
Contributor II

Hai Prashant,

Its amazing!!!  Its working fine after doing it as you said.

Thanks 

0 Kudos
1,675 Views
prashant_humbre
Contributor II

I am glad this worked. I also had spent a day on this problem!

Looks like a bug in MCUXpresso IDE or in Flash Tool.

I hope NXP will handle this issue asap!

MCUXpresso IDE

0 Kudos
1,675 Views
BlackNight
NXP Employee
NXP Employee

See Using Eclipse to Program Binary Files to an Embedded Target | MCU on Eclipse : the P&E connection only can program a binary of type ELF/Dwarf. That article describes how you can convert a bin file into an ELF/Dwarf one, but this is not possible for S19.

I hope this helps,

Erich

0 Kudos
1,675 Views
kaarthick
Contributor II

I am getting same console output for any type of file flashing (.hex , .bin , .axf). Can you share how to use GUI Flash tool for external hex or axf file flash?

0 Kudos
1,675 Views
BlackNight
NXP Employee
NXP Employee

With the P&E connection, you only can use .axf files.

See Using Eclipse to Program Binary Files to an Embedded Target | MCU on Eclipse 

and especially Overview of MCUXpresso IDE v10.2.0 | MCU on Eclipse  (search for section 'GUI Flash Tool extended for P&E and SEGGER').

I hope this helps,

Erich

0 Kudos
1,675 Views
kaarthick
Contributor II

I am getting error like this also.

Executing flash operation 'Program' (Program file into flash: MK10DN512xxx10_Project.axf) - Tue Jul 23 09:17:58 IST 2019
Checking MCU info...
Scanning for targets...
Executing flash action...
P&E GDB Server for Arm(R) devices, Version 6.83.00.00
Copyright 2018, P&E Microcomputer Systems Inc, All rights reserved
Loading library C:\NXP\MCUXpressoIDE_10.2.1_795\ide\plugins\com.pemicro.debug.gdbjtag.pne_3.5.6.201805161649\win32\gdi\unit_ngs_arm_internal.dll ... Done.
Command line arguments: -interface=USBMULTILINK -port=USB1 -speed=5000 -flashobjectfile=E:\kaarthick\04072019 bootloader\05072019 bootloader\MK10DN512xxx10_Project\Debug\MK10DN512xxx10_Project.axf -device=NXP_K1x_K10DN512M10 -programmingtype=0 -runafterprogramming -startserver -singlesession -quitafterprogramming
Device selected is NXP_K1x_K10DN512M10
User Specified Hardware Selection : Interface=USBMULTILINK and Port=USB1
Connecting to target.
P&E Interface detected - Flash Version 9.93
Can not enter background mode .
Unable to initialize PEDebug.
PEmicro GDB Launch Failure : The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.
Target Disconnected.
Flash command failed!
Unable to perform operation.

Can you solve is this issue?

0 Kudos
1,675 Views
BlackNight
NXP Employee
NXP Employee

Hi Karthik,

are you able to debug your board ina the normal way (just use one of the provided example projects in the SDK).

I ask because

PEmicro GDB Launch Failure : The GDB Server was not able to establish a connection to the target processor. Please check your connections and power. Verify that the launch settings in the Debug Configuration are accurate.

indicates that either your board is not powered or not connected at all.

Additionally, your log indicates you are using the V10.2 of the IDE, I recommend that you are installing and trying the V11 (see New NXP MCUXpresso Eclipse IDE v11.0 | MCU on Eclipse ). Because the never version comes with updated and extended drivers/plugins for P&E. You don't have to uninstall your 10.2: simply have the V11 installed into a different folder.

I hope this helps,

Erich

0 Kudos
1,675 Views
kaarthick
Contributor II

Thanks Erich, 

I tried to flash .axf file with flash GUI tool, but nothing is flashed. I didn't change ide version. I check and tell you. Shall I flash axf file of one project into another project via GUI flash tool? 

Is there any other way to flash .axf or hex or s19 file to nxp controller by using pe micro debugger??

0 Kudos
1,675 Views
BlackNight
NXP Employee
NXP Employee

I recommend that you try this with a 'blinky' project. I would start using the flash programmer for that project, and once verified you can load a different .axf. Make sure you check the log: if it fails you should see an error message or something similar indicating the error.

0 Kudos
1,675 Views
kaarthick
Contributor II

Hai Erich,

I tried own axf file of same project for GUI Flash Programmer. But No one helps me.

Can you share me best way to flash .axf or .elf or .hex with GUI Flash Programmer.

Is there any flexible document for that?

0 Kudos
1,675 Views
BlackNight
NXP Employee
NXP Employee

pastedImage_1.png

and search then for 'GUI Flash Tool'.

0 Kudos
1,675 Views
kaarthick
Contributor II

Hai Erich,

After installing MCUXpresso 11 , I am getting the same error. Refer image below

test.png

0 Kudos