OpenSDA KL28 KDS

cancel
Showing results for 
Search instead for 
Did you mean: 

OpenSDA KL28 KDS

Jump to solution
809 Views
Contributor I

Dear all,

I have been using the FRDM-KL26 board with KDS and OpenSDA with success. I have switched to the FRDM-KL28 but cannot make it works.

BOOTLOADER does not appear ... instead I see a DAPLINKBOOT ???  The firmware for OpenSDA I found on the PME website does not list the KL28Z ... Not supported?

Basically, the question is how can I make the FRDM-KL28Z work with KDS (v3.1.0) for programming and debugging?

Thank you very much for your help.

Andre

0 Kudos
1 Solution
353 Views
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!

View solution in original post

0 Kudos
14 Replies
354 Views
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!

View solution in original post

0 Kudos
315 Views
Senior Contributor II

I do hope someone turns off this Bot.  Bringing long dead posts back to life are just wasting everyone time to look at them, just to find it is a long dead post that the bot brought back to life...

0 Kudos
353 Views
NXP Employee
NXP Employee


Andre:

Just take it easy.

Yes, on FRDM-KL28, there's some change.

When you see DAPLINKBOOT, it shows the board is working correctly.

And as you want to use KDS, you need to update the FW from MBED to JLINK.

I attached the JLink FW in binary format here, you can drag it to the DAPLINKBOOT disk when you see it, and re-connect the board, JLINK would be working.

If you still have any issue, please visit the following link and read step 3 carefully, I believe it would shoot the issues you meet.

FRDM-KL28Z|Freedom Development Platform|Kinetis MCU|NXP

0 Kudos
353 Views
Contributor I

Dear Jia,

I have been trying as you suggested ... unfortunately, I have still an error with GDB trying debugging the Hello-World example for the FRDM-KL28. The error is:

pastedImage_0.png

So, i have de-install and re-install KDS 3.2.0 and JLink - V600 but to no avail.  I haven't changed anything in the debugger setting of the Hello-World example. The board is connected to Tera Term with success and the OpenSDA 2.1 seems to be loaded correctly (as for Tan, I don't see the disk drive).

Starting the command above in a prompt gives this:

pastedImage_0.png

Any suggestion ? Thank you.

Regards

0 Kudos
353 Views
NXP Employee
NXP Employee

Hi Andre,

It seems that the issue is resulted from the command that KDS calls JLink GDB Server. I find there are additional contents in the command from the error report you provided. Please see the below figure.

Capture.PNG

Do you run the hello_world demo from "SDK_2.0_FRDM-KL28Z" and made no changes of the project?

Could you provide the debug configurations information followed the below steps?

1. Import the hello_world project to you workspace.

2. Click the small downward arrow next to the green "Debug" button and select "Debug Configurations".

pastedImage_1.png

3. In the Debug Configurations dialog box, select debug configuration “hello_world_frdmkl28z debug jlink”. Then click the "Debugger" tab to open the debugger configuration page.

debug-config-1.PNG

4. Please let me know the content in the text box next to the "Executable" label. Is it  "${jlink_path}/${jlink_gdbserver}" just like mine? If not, please modify it as mine and then try the debugging process again. If it is, please proceed the followed steps.

debug-config-2.PNG

5. Click the "Variables..." button to open a new window. Then click the "Edit Variables" button to open another window.

Variables.PNG

6. Please feedback me the value of the "jlink_path" variable.

Variables-2.PNG

Thanks.

Dean

Best Regards,
Dean
0 Kudos
353 Views
Contributor I

Dear Dean,

thank you very much for your feedback.

>>>>> Do you run the hello_world demo from "SDK_2.0_FRDM-KL28Z" and made no changes of the project?

I made no change to the project. My folder is named SDK_FRDM_KL28Z.

>>>>>   Is it  "${jlink_path}/${jlink_gdbserver}" just like mine?

No it was:  ${jlink_gdbserver}${jlink_gdbserver}${jlink_path}/${jlink_gdbserver}. So I have changed the path to

${jlink_path}/${jlink_gdbserver} and it works. I have just noticed that clicking the "Variables ..." button of the GUI and closing the new pop-up window  by clicking "OK" (and not Cancel), always add a variable name to the executable variable field and that although the variable name does not appear on the field just below the "Choose a variable" of the pop-up window... it might have happened to me inadvertently while checking if the JLink path was correct in KDS ?????

>>>>> Please feedback me the value of the "jlink_path" variable

My path is C:/Program Files (x86)/SEGGER/JLink_V600d

For me the issue is solved. Thank you Dean and all of you for your support.

Regards Andre

0 Kudos
353 Views
NXP Employee
NXP Employee

valeremar

This issue seems exist in the configuration of the KDS project, my colleage Dean would provide more information to you later.

0 Kudos
353 Views
Contributor I

Dear Jia,

I was offline for 2 days. I apologize for the delays. Inbetween, I have tried different solutions with respect to information I have found, including the link you have sent ... no luck..

So in the next step,  I will be trying with the file you have just sent ... and I will let you know how it goes.

Thank you for your help.

Regards, Andre

0 Kudos
353 Views
Contributor I

Hi Jia Guo,

I used the Jlink_OpenSDA_V2.1.bin for my KL28Z, but after flashed it in bootloader, when in normal mode I can't see the disk drive enumerated anymore, it that something that expected to happen?

Thanks.

0 Kudos
353 Views
NXP Employee
NXP Employee

Hi,Tan:

Yes, that is expected. The FW I attached does not make a disk drive there.Just need to check if the JLINK function is available.

The JLINK CDC console is also supported in the FW.

0 Kudos
353 Views
NXP Employee
NXP Employee

Hi Andre,

I don't have a FRDM-KL28Z, but I know that DAPlink is the new bootloader on the FRDM boards. What host operating system are you using? If using Windows 8 or 10, then be aware that the host might affect the bootloader. It happened to me with the OpenSDA V2 on FRDM-K64F and FRDM-K22F, and I have published a solution here: https://mcuoneclipse.com/2016/06/26/how-to-recover-the-opensda-v2-x-bootloader/

You find firmware files for all the boars on the NXP OpenSDA site here: OpenSDA Serial and Debug Adapter|NXP

Erich

0 Kudos
353 Views
Contributor I

Thank you Erich for your quick reply. I am using Windows 10.

I have already visited the link you have provided for NXP OpenSDA but the KL28z is not listed !!! (Under the section: Download -OpenSDA Bootloader and Application)

Which one can I  use safely ? Any OpenSDA v2 or v2.1 ?

Best Andre

0 Kudos
353 Views
NXP Employee
NXP Employee

Hi Andre,

I should have checked first myself, indeed it is not listed. I'll have pinged NXP internally to fix that.

OpenSDA v2 is only for the FRDM-K64F board, everything else (FRDM-K22F, ...) is using v2.1. The difference is that V2 assumes 0x5000 as base address, while V2.1 assumes 0x8000 address. I would use the v2.1.

You could use both, the bootloader would reject it if the addresses do not match.

I hope this helps,

Erich

0 Kudos
353 Views
Contributor I

Dear Erich,

I have been investigating but without luck so far.

I have found the KL28 listed under the segger webpage. They refer to to the OpenSDA version 2.0.

I have also tried to communicate with the board using the SWD protocol (as I use to do with another board), but KDS send me an error while debugging: "Time Out trying to lauch GDP Server" (using PME Multilink universal). I have to do some reading here ... I have followed instructions in ''FRDM-KL28Z User's Interface'' that is cutting the J18 pins (p6).

I am still however trying with OpenSDA which is more comfortable for debugging.

Well I am still stuck ... no being able to communicate with the board. It is annoying.

Best Andre

0 Kudos