LK05Z IAR

cancel
Showing results for 
Search instead for 
Did you mean: 

LK05Z IAR

Jump to solution
492 Views
Specialist II

Hello,

I have an KL05Z board. I have open SDA CDC port working and I can drag and drop programs to the board but I am totally unable to make my KL05Z work with IAR free evaluation, code length limited version. I get the following error when atempting to download the code to the board: Fatal error: Failed to initialize PEMicro interface DLL.   Session aborted!  I have tried almost everything...

Please, help!

Thanks,

Manuel

Labels (1)
0 Kudos
1 Solution
26 Views
Specialist II

Hector,

I now got it working, at last! the "OpenSDA Debug Driver" was missing

under "Jungo"

I have found the installation of the drivers very tricky... :smileysad: Whish they

improve it!

Thanks for your kind help. Regards,

Manuel

2013/12/2 Hector Sanchez <admin@community.freescale.com>

<https://community.freescale.com/> Re: LK05Z IAR

reply from Hector Sanchez<https://community.freescale.com/people/hectorsanchez?et=watches.email.thread>in *Kinetis

Hardware Support* - View the full discussion<https://community.freescale.com/message/366181?et=watches.email.thread#366181>

View solution in original post

0 Kudos
4 Replies
26 Views
Contributor IV

Hi Manuel,

Probably it's because you are missing the drivers from P&E Microcomputer Systems, i recommend you to download and install them here: http://www.pemicro.com./ Hope this helps, keep me informed.

Best Regards,

Hector Sanchez

0 Kudos
26 Views
Specialist II

Thanks Hector,

I did download and install the drivers several times but probably, for some

uknown reason, they refuse to install corectly. I attach a screenshot of

my device manager after the installation. Can you please tell me what is

wrong or missing? I am on Windows7 64bits.

Thanks for your help,

Manuel

2013/12/2 Hector Sanchez <admin@community.freescale.com>

<https://community.freescale.com/> LK05Z IAR

reply from Hector Sanchez<https://community.freescale.com/people/hectorsanchez?et=watches.email.thread>in *Kinetis

Hardware Support* - View the full discussion<https://community.freescale.com/message/366172?et=watches.email.thread#366172>

0 Kudos
26 Views
Contributor IV

Hi Manuel,

Maybe your board is not in OpenSDA Debug mode, here is a quick tutorial on how to enter the Bootloader mode to configure your board as a debugging interface.
I will provide you with an example on how to configure your board provided by Erich Styger's blog: OpenSDA on the Freedom KL25Z Board | MCU on Eclipse

I will leave the Quick Start Guide if you need it too.

Keep me informed,

Hector Sanchez

27 Views
Specialist II

Hector,

I now got it working, at last! the "OpenSDA Debug Driver" was missing

under "Jungo"

I have found the installation of the drivers very tricky... :smileysad: Whish they

improve it!

Thanks for your kind help. Regards,

Manuel

2013/12/2 Hector Sanchez <admin@community.freescale.com>

<https://community.freescale.com/> Re: LK05Z IAR

reply from Hector Sanchez<https://community.freescale.com/people/hectorsanchez?et=watches.email.thread>in *Kinetis

Hardware Support* - View the full discussion<https://community.freescale.com/message/366181?et=watches.email.thread#366181>

View solution in original post

0 Kudos