long delay between chars when using SPI(FRDM-K64F)

cancel
Showing results for 
Search instead for 
Did you mean: 

long delay between chars when using SPI(FRDM-K64F)

Jump to solution
501 Views
lingqian
Contributor II

Hi there,

 

Has anyone met a problem when setting SPI delays (delay between chars) in Processor Expert?

 

My project is sending some data to a DAC via SPI and I used PE to do the settings. When the clock rate is around 1MHz, everything works fine and I can set the delay between chars to around 1.44us. However, when I increase the clock rate to a higher frequency, say 10MHz, and remain the delay between chars to 1.44us, the delay I get from logic analyzer becomes 5us.

 

I didn't change any code or settings except the clock rate, so I am really confused about this situation.

Anyone has any idea about this problem?

 

Thanks,

Ling

Labels (1)
1 Solution
198 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi Ling Q,

Please take a look to the recommendations made on the following post to avoid this delay between SPI transmissions:

Re: Long ~30uS delay between SPI byte transmissions in fsl_dspi during call to DSPI_DRV_MasterTransf...

Hope it helps!

Best Regards,

Carlos Mendoza

Technical Support Engineer

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

2 Replies
199 Views
Carlos_Mendoza
NXP Employee
NXP Employee

Hi Ling Q,

Please take a look to the recommendations made on the following post to avoid this delay between SPI transmissions:

Re: Long ~30uS delay between SPI byte transmissions in fsl_dspi during call to DSPI_DRV_MasterTransf...

Hope it helps!

Best Regards,

Carlos Mendoza

Technical Support Engineer

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

198 Views
lingqian
Contributor II

Hi Carlos Mendoza,

Thanks for your quick reply.

I increased the core frequency of MK24FN1M0VLL12 to 120MHz using the first method in FRDM-K64F at Maximum Speed of 120 MHz | MCU on Eclipse  and then my problem solved.

Thanks again.

Regards,

Ling