CW10.6 & FLASH Programmer Error - 56F8323

cancel
Showing results for 
Search instead for 
Did you mean: 

CW10.6 & FLASH Programmer Error - 56F8323

Jump to solution
918 Views
v_dave
Contributor IV

Hello,

 

We have used in the past the older standalone 56800E Flash Programmer app that came with the CW8.x tools.  We have upgraded our PC to a WIN7 Pro machine now we are trying to use newer tools for production programming of our products.  We have installed CW10.6.4 and setup the FLASH Programmer as a Task.

 

48215_48215.pngpastedImage_0.png

 

I am able to connect to the USB Tap and everything seems to start OK:

 

Beginning Operation ...   

 

-------------------------

 

Auto-detection is successful.  

 

  File is of type Motorola S-Record Format.  

 

 

 

Auto-detection is successful.  

 

  File is of type Motorola S-Record Format.  

 

 

 

Erasing ..............

 

Error:  Erase Command Failed.   Protect violation error.

 

Error: Erase Command Failed. Protect violation error.

 

fl::target -lc "LC for Simple Flash"

 

fl::target -b 0x2fc00 0x400

 

fl::target -v off -l off

 

cmdwin::fl::device -d "MC56F8323_P_FLASH" -o "68kx16x1" -a 0x0 0x20fff

 

cmdwin::fl::protect all off

 

Beginning Operation ...   

 

-------------------------

 

Performing target initialization ...   

 

Flash Operation.  

 

Unprotecting .............  

 

Unprotect Command Succeeded.  

 

cmdwin::fl::erase all

 

-------------------------

 

Erasing ..........

 

Error:  Erase Command Failed.   Protect violation error.

 

Error: Erase Command Failed. Protect violation error.

 

My Setups look like this:

48217_48217.pngpastedImage_3.png

 

48218_48218.pngpastedImage_6.png

 

48219_48219.pngpastedImage_9.png

 

48220_48220.pngpastedImage_12.png

 

48221_48221.pngpastedImage_15.png

 

So as you can see it appears everything is setup correctly and I have tried multiple target boards.  Any ideas on how to correct the "Error:  Erase Command Failed.   Protect violation error." would be great.

 

Thanks,

Dave

Labels (1)
0 Kudos
1 Solution
262 Views
TICS_Fiona
NXP Employee
NXP Employee

Hi,

CodeWarrior v10.6.4 has problem in programming 56F8323 with USBTAP, user needs to manually update the .tcl and xml file in CodeWarrior and project folder. For details, please refer to:

https://community.freescale.com/docs/DOC-105548

In addition, 56800E Flash Programmer v1.2 also works on Windows 7-64bit,  please copy the CCS folder in CW10.6.4 and use it to replace the one under 56800E Flash Programmer v1.2. For details, pleases refer to:

https://community.freescale.com/docs/DOC-102607

Fiona Kuang

Technical Information & Commercial Support

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
263 Views
TICS_Fiona
NXP Employee
NXP Employee

Hi,

CodeWarrior v10.6.4 has problem in programming 56F8323 with USBTAP, user needs to manually update the .tcl and xml file in CodeWarrior and project folder. For details, please refer to:

https://community.freescale.com/docs/DOC-105548

In addition, 56800E Flash Programmer v1.2 also works on Windows 7-64bit,  please copy the CCS folder in CW10.6.4 and use it to replace the one under 56800E Flash Programmer v1.2. For details, pleases refer to:

https://community.freescale.com/docs/DOC-102607

Fiona Kuang

Technical Information & Commercial Support

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos