MQX10.4 Error in Flash Programmer: Initialization Failed

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX10.4 Error in Flash Programmer: Initialization Failed

Jump to solution
343 Views
Contributor IV

Good morning,

I use MQX4.1.01 with CW10.4, the micro is MCF52255. I'd like to flash the micro with the demo software "web_hvac_twrmcf52259". I want to flash by the Flash Programmer, other procedures gave me error, too.

I use the PE Micro Multilink Universal. The settings are shown in the figure Settingx. When I flash the micro, I always get the error: Initializion failed.

I don't change the sourc of the libraries and the demo project.

I referred to the file .cfg and .mem in the lib directory for the micro MCF5229.

Why do I get the error?

What I have to change?

 

Thank you

Best Regards

Mirko

 

Error

14177_14177.jpgError_initialization failed.jpg

Setting1

14178_14178.jpgSetting1.jpg

Setting2

14179_14179.jpgSetting2.jpg

Setting3

14180_14180.jpgSetting3.jpg

Setting4

14181_14181.jpgSetting4.jpg

Labels (1)
0 Kudos
1 Solution
114 Views
NXP Employee
NXP Employee

I only have a 52259, so cannot verify it with a 52255. I'm using CW for MCU10.6, and here it creates the cfg and mem file for me.

I think you cannot use the 52259 files for your 52255, because the memory does not match.

So don't use the wrong files, use the ones inside/from the project:

pastedImage_0.png

Just in case, I have my project attached so you can take it from there too.

I hope this helps,

Erich

View solution in original post

0 Kudos
4 Replies
114 Views
NXP Employee
NXP Employee

Does normal debugging/dowloading work?

Is your device a 52259 (because you say above MCF52255)?

0 Kudos
114 Views
Contributor IV

Hi Erich,

yes it is a normal debugging/downloading work.

I try to flash a my board where it is present MCF52255, so I use the configuration files of MCF52259, I don't find a configuration file MCF52255_INTFLASH.

Mirko

0 Kudos
115 Views
NXP Employee
NXP Employee

I only have a 52259, so cannot verify it with a 52255. I'm using CW for MCU10.6, and here it creates the cfg and mem file for me.

I think you cannot use the 52259 files for your 52255, because the memory does not match.

So don't use the wrong files, use the ones inside/from the project:

pastedImage_0.png

Just in case, I have my project attached so you can take it from there too.

I hope this helps,

Erich

View solution in original post

0 Kudos
114 Views
Contributor IV

Hi Erych,

I found the .cfg and .mem in the CW10.4 installation directory and now the flashing is working.

Thank you

Best Regards

Mirko

0 Kudos