Bareboard project for MPC5634M in CodeWarrior v10.6.4, Error -1073741811 at build

cancel
Showing results for 
Search instead for 
Did you mean: 

Bareboard project for MPC5634M in CodeWarrior v10.6.4, Error -1073741811 at build

891 Views
buraksoner
Contributor II

I'm using CodeWarrior version v10.6.4

 

When I create a new Bareboard Project for and try to build it (no changes on the generated project source files) I get the following errors:

 

mingw32-make: *** [Sources/IntcInterrupts_c.obj] Error -1073741811

mingw32-make: *** Waiting for unfinished jobs....

mingw32-make: *** [Sources/ivor_branch_table_c.obj] Error -1073741811

mingw32-make: *** [Project_Settings/Startup_Code/__ppc_eabi_init_c.obj] Error -1073741811

mingw32-make: *** [Project_Settings/Startup_Code/MPC5634M_Startup_c.obj] Error -1073741811

mingw32-make: *** [Sources/main_c.obj] Error -1073741811

mingw32-make: *** [Sources/Exceptions_c.obj] Error -1073741811

mingw32-make: *** [Project_Settings/Startup_Code/MPC5634M_HWInit_c.obj] Error -1073741811

mingw32-make: *** [Project_Settings/Startup_Code/MPC5634M_init_ram_c.obj] Error -1073741811

 

Does anybody know what this error means or how to solve it?

Labels (1)
0 Kudos
8 Replies

255 Views
buraksoner
Contributor II

Hello Martin,

I probably won't be able to uninstall everything on my "erroneous" computer like you said for at least 1-2 months as this is a computer used in like 5-6 projects all with custom tools installed with setup files I probably don't have anymore :smileyhappy:. If I do this and find a cause for this I'll write it here.

Thanks for the support,

Burak

0 Kudos

255 Views
TICS_Fiona
NXP Employee
NXP Employee

Hello Burak

It seems that there’s some problem with the CodeWarrior installation or with the workspace.
Please delete .metadata folder of workspace of CW 10.6.

Then reopen the project in CodeWarrior, and click on 'Project' menu-> Clean to remove the old object file, and then rebuild the project. Is the problem fixed?

If not, please create a new bareboard project for your target MCU, can CW build it successfully?
In addition, the latest CodeWarrior version is v10.6.6.

Please first install CW10.6.4 which can be downloaded from:
www.freescale.com/cwmcu10

Its update v10.6.5 and  v10.6.6 are also available at the same link.

Further information and the release notes are available on the following Freescale community page:
https://community.freescale.com/docs/DOC-143655
 

Best Regards

Fiona Kuang

TIC - Technical Information Center

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Mark Correct button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

255 Views
buraksoner
Contributor II

Hello Xin,

I've done the following:

1- Updated CW with updates 5 and 6.

2- Deleted .metadata folder, reopened CW, imported my project, cleaned my project, rebuilt it -> same error occurs

3- Deleted my project (also the contents on the disk)

4- Created a new Bareboard project with the following steps shown:

     A)

pastedImage_2.png

     B)

pastedImage_5.png

     C)

pastedImage_6.png

     D)

     pastedImage_7.png

5- Closed CW, deleted .metadata, opened CW, built this new project "teest" -> still the same errors

Is there something wrong with the toolchain? Do I maybe need to install also some tools other than CW 10.6.6 to compile C projects?

Regards,

Burak

0 Kudos

255 Views
TICS_Fiona
NXP Employee
NXP Employee

Hello Burak

Please log on Windows and run CodeWarrior as administrator. If this does not help, it seems that there’s some problem with the CodeWarrior installation. Could you please completely uninstall this software, restart Windows, then install CodeWarrior again. Does it work?

Best Regards

Fiona Kuang

TIC - Technical Information Center

0 Kudos

255 Views
buraksoner
Contributor II

Hello Xin,

I've done the following:

1- Logged onto Windows with an administrator account, ran CodeWarrior as administrator -> same errors

2- Uninstalled/reinstalled CW by running the setup file as administrator and then launching CW as administrator -> same errors

Just as a disclaimer after I read posts complaining about similar errors -> my installation path does not contain spaces.

Could this be a problem related to the mingw32-make utility? Because it seems the source files get lined up for build but the build never occurrs because of this error... Are there any known conflicts between other programs which may be using this utility?

Regards,

Burak

0 Kudos

255 Views
martin_kovar
NXP Employee
NXP Employee

Hi Burak,

I found some thread where the similar issue was solved.

Code warrior 10.2 kinetis kwikstik project mingw make error

Also look at this thread. I am not sure, but it should be problem with installation paths.

the error of IDES32 Design Studio for ARM v1.1 - Windows installation fail

Regards,

Martin

0 Kudos

255 Views
buraksoner
Contributor II

Hello Martin,

Thanks for the reply. Unfortunately I couldn't find a solution on neither of the threads. I'm suspecting this is an issue related to other tools installed on my computer as I've tried exactly the same installation procedure on an identical model/make computer and this problem does not occur.

Looks like there's a conflict of some sort between Code Warrior and another tool (possibly using the same make utility)... Is this something you've faced/heard before?

Regards,

Burak

0 Kudos

255 Views
martin_kovar
NXP Employee
NXP Employee

Hello Burak,

I had also consulted this issue with one of my colleague and we have never faced this problem yet. From your description it really looks like a problem in your operating system (some dependencies misses or maybe operating system is damaged).

Are you able to reinstall your operating system and try to install CW again?

Regards,

Martin

0 Kudos