Compile L2.6.35_1.1.0_130130 for i.MX28 on Ubuntu 12.04 64bit OS

Document created by Isaac Ng Employee on Dec 9, 2013Last modified by Isaac Ng Employee on Dec 9, 2013
Version 1Show Document
  • View in full screen mode

This is the procedure and patch to set up Ubuntu 12.04 64bit Linux Host PC and building i.MX28 L2.6.35_1.1.0_130130.  It has been tested to build GNOME profile and with FSL Standard MM codec.

 

A) Basic Requirement:

 

  • Set up the Linux Host PC using ubuntu-12.04.3-desktop-amd64.iso
  • Make sure the previous LTIB installation and the /opt/freescale have been removed

 

B) Installed the needed packages to the Linux Host PC

 

$ sudo apt-get update

 

$ sudo apt-get install gettext libgtk2.0-dev rpm bison m4 libfreetype6-dev

$ sudo apt-get install libdbus-glib-1-dev liborbit2-dev intltool

$ sudo apt-get install ccache ncurses-dev zlib1g zlib1g-dev gcc g++ libtool

$ sudo apt-get install uuid-dev liblzo2-dev

$ sudo apt-get install tcl dpkg

$ sudo apt-get install asciidoc texlive-latex-base dblatex xutils-dev

$ sudo apt-get install texlive texinfo

$ sudo apt-get install ia32-libs libc6-dev-i386 lib32z1

$ sudo apt-get install uboot-mkimage

 

$ sudo apt-get install scrollkeeper

 

$ sudo apt-get install gparted

$ sudo apt-get install nfs-common nfs-kernel-server

$ sudo apt-get install git-core git-doc git-email git-gui gitk

$ sudo apt-get install meld atftpd

 

C) Unpack and install the LTIB source package and assume done on the home directory:

 

$ cd ~

$ tar -zxvf L2.6.35_1.1.0_130130_source.tar.gz

$ ./L2.6.35_1.1.0_130130_source/install

 

After that, you will find ~/ltib directory created

 

D) Apply the patch to make L2.6.35_1.1.0 could be installed and compiled on Ubuntu 12.04 64bit OS

 

$ cd ~/ltib

$ git apply 0001_make_L2.6.35_1.1.0_130130_compile_on_ubuntu_12.04_64bit_OS.patch

 

a) The patch modifies the following files:

    •    dist/lfs-5.1/base_libs/base_libs.spec
    •    dist/lfs-5.1/lkc/lkc.spec
    •    dist/lfs-5.1/mux_server/mux_server.spec
    •    dist/lfs-5.1/ncurses/ncurses.spec

 

b) Add the following files to the pkgs directory:

    •    pkgs/lkc-1.4-lib.patch
    •    pkgs/lkc-1.4-lib.patch.md5

 

E) Then, it is ready to proceed the rest of the LTIB env setup process:

 

$ cd ~/ltib

$ ./ltib -m config

$ ./ltib

 

Reference:

 

NOTE:

 

When compiling gstreamer, this warning was pop up.  Just ignore it seems okay.

 

panel.jpg

 

panel2.jpg

Outcomes