AnsweredAssumed Answered

Wire not connected on Q9080-DX LinkServer

Question asked by Rick Dickerson on Mar 21, 2018
Latest reply on Apr 3, 2018 by Rick Dickerson

I have a new Q9080-DX development board that I am trying to debug through the LinkServer CMSIS-DAP interface on a Windows 10 machine using MCUXpresso 10.1.1. I have successfully pushed two example projects to the board and was able to debug them, but I can't connect to the board anymore (the error message is below) for either of those projects. It stopped working while I was developing, so the IDE and development board were in the same state as the previous successful debugging session. No changes were made to the debug configuration between the last successful debugging session and the beginning of the failures. The last application I pushed into the QN9080 is still working, so that chip appears to be alive.

 

I think the LPC hardware is still working and configured properly because I still see the virtual comm port in the Windows Device Manager and the probe can be discovered by the debugger. However, when I try to debug the application I get an error stating that the wire is not connected. I have tried restarting MCUXpresso, rebooting the PC, starting a new workspace and deleting and recreating the debug configuration to no avail. The LPC driver version is 2.0.0.0, which I think is up to date.

 

After the failure, the MCUXpresso IDE status bar says that it killed redlinkserv.exe, but I can see the process is still running in the task manager. I tried manually killing that process but it didn't help.

 

I would appreciate any help someone can provide in getting this board back up and running. 

 

 

Outcomes