AnsweredAssumed Answered

LTIB GTK build Error for iMX6

Question asked by praveeng on Oct 22, 2012
Latest reply on Jun 6, 2013 by Makis Livadas

 

Hello,

 

I have a iMX6 Sabrelite development board. I have a Ltib 2,6,38 version for the same board.

 

While compiling on 64 bit Ubuntu 12,04LTS , I find the build fails because of gtk error (f_buildrpms() returned an error,) been repeated ...

 

Further I have checked in internet and tried some solutions like installing all packages related to gtk, cairo etc and other solutions like bash, building cairo before ./ltib, but I fail to build the LTIB with the same error....

 

In the ./ltib -m config , I even cannot disable gtk and cairo.

 

Can you please suggest and idea or solution?

 

Please give some solutions, I am stuck since a long time.

 

 

The following is a brief report of the failed build.

 

 

 

checking for libpng12... yes

 

checking pixbuf loaders to build...

 

checking immodules to build...

 

checking for sys/wait.h that is POSIX.1 compatible... yes

 

checking return type of signal handlers... (cached) void

 

checking sys/systeminfo.h usability... no

 

checking sys/systeminfo.h presence... no

 

checking for sys/systeminfo.h... no

 

checking sys/sysinfo.h usability... yes

 

checking sys/sysinfo.h presence... yes

 

checking for sys/sysinfo.h... yes

 

checking for mediaLib 2.3... checking for mlib_ImageSetStruct in -lmlib... no

 

checking for x86 platform... no

 

checking for gdk-pixbuf-csource... /usr/bin/gdk-pixbuf-csource

 

checking for gtk-update-icon-cache... /usr/bin/gtk-update-icon-cache

 

checking for X... no

 

configure: error: X development libraries not found

 

error: Bad exit status from /home/praveen/freescale/ltib/tmp/rpm-tmp.26100 (%build)

 

 

 

RPM build errors:

 

Bad exit status from /home/praveen/freescale/ltib/tmp/rpm-tmp.26100 (%build)

 

Build time for gtk2: 15 seconds

 

Failed building gtk2

 

 

 

f_buildrpms() returned an error, exiting

 

traceback:

 

main:560

 

 

 

Started: Mon Oct 22 00:08:17 2012

 

Ended: Mon Oct 22 00:08:33 2012

 

Elapsed: 16 seconds

 

These packages failed to build:

 

gtk2

 

Build Failed

 

Outcomes