i.MXRT 1052 Debug Error: Failed to execute MI command if I use the GPIO1.25 pin

cancel
Showing results for 
Search instead for 
Did you mean: 

i.MXRT 1052 Debug Error: Failed to execute MI command if I use the GPIO1.25 pin

Jump to solution
196 Views
ivy_shi
Contributor II

Hi,

I have meet a wired issue. I use MCUXpresso IDE V11.5.1 on windows 10 PC with Jlink Plus debug tool and NXP MIMX1052CVL5B as a target. I load a SDK example and modify the configuration to use the Jlink's flash driver. and it works and I could load my code to my target successfully. but once I config the M13 pin(GPIO1.25) as GPIO output. I will get an issue as below, I could not load/debug my project. and if I remove the GPIO1.25 configuration, I will load/debug my code sucessfully. so does anyone else meet the issue? need your help.

ivy_shi_0-1657012633977.png

and console log as below, more info as attched txt.

ivy_shi_0-1657014033499.png

Note: my HW as below. and my SW package as attached.

ivy_shi_0-1657013279259.png

ivy_shi_1-1657013355410.png

ivy_shi_0-1657014966937.png

Note: at present, I remove the R284 & R281.

Labels (1)
0 Kudos
1 Solution
187 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thank you for your interest in NXP Semiconductor products and for the opportunity to serve you.
For QSPI Flash as XIP function, to achieve the highest performance it is recommended to leave the FLEXSPI_A_DQS pin floating and configure the sample clock source as 01-loopback from DQS pad mode to achieve max 133MHz Flexspi_clk. Besides, it is also recommended to pull up QSPI flash
pin1(CE) and pin7(hold) to make sure QSPI Flash boot-up stability
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------
To provide the fastest possible support, I'd highly recommend you to refer to the post:

View solution in original post

0 Kudos
2 Replies
184 Views
ivy_shi
Contributor II

Thanks for your reply. and I found the reason. I have configed the clock source as 01-loopback from DQS pad mode, that why I can't config the M13 pin as GPIO feature.

0 Kudos
188 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
Thank you for your interest in NXP Semiconductor products and for the opportunity to serve you.
For QSPI Flash as XIP function, to achieve the highest performance it is recommended to leave the FLEXSPI_A_DQS pin floating and configure the sample clock source as 01-loopback from DQS pad mode to achieve max 133MHz Flexspi_clk. Besides, it is also recommended to pull up QSPI flash
pin1(CE) and pin7(hold) to make sure QSPI Flash boot-up stability
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------
To provide the fastest possible support, I'd highly recommend you to refer to the post:

0 Kudos