i.mx6 plugin image with HAB

cancel
Showing results for 
Search instead for 
Did you mean: 

i.mx6 plugin image with HAB

395 Views
oferfederovsky
Contributor III

Hi,

I'm switching modes, from DCD, to plugin image.

All seems fine, as long as the HAB is disabled (SEC_CONFIG is not in close mode).

Once I try to run with close mode, boot fails.

In open-mode, I see this hab-status, in endless loop:

U-Boot > hab_status
iMX6 HAB status Information :
=============================
HAB Configuration: 0x00 HAB State: 0x00
--------- HAB Event 1 -----------------
event data:
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x84 0x30 0x28 0x12
   0x84 0x30 0x28 0x12 0x74 0x0a 0x81 0x27
   0x47 0xbb 0x81 0x27 0x01 0x00 0x00 0x00
   0xed 0x6b 0x83 0x27 0x09 0x00 0x00 0x00
   0xb0 0xd4 0x81 0x27 0xbc 0xc8 0x80 0x27
   0xd2 0x00 0x00 0x00 0xc0 0x39 0x60 0x27

* With DCD + HAB close mode, I have no issues.

* I'm using i.mx6q, with u-boot 2009 (yes, I know it is very old..).

Any idea what may be the cause for this HAB failure?

Thank you in advance

Ofer

Labels (2)
0 Kudos
1 Reply

114 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  Sorry, but the information you are requesting is treated as confidential info at this time and requires a signed NDA . Naturally, we cannot discuss this with you in public anyway, this requires to be handled as a Service Request.

https://community.nxp.com/docs/DOC-329745 

Have a great day,
Yuri

-------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button.
Thank you!

0 Kudos