fbGetDisplay with Yocto build

cancel
Showing results for 
Search instead for 
Did you mean: 

fbGetDisplay with Yocto build

1,448 Views
BrianEdmond
Contributor II

Hi,

I have built a yocto image for a Nitrogen6X board and would like to run an OpenGL ES 2.0 application without X11.  I have built an image which does not have X11 but can not figure out how to configure EGL.  In previous images, like the boundary devices stock image, I could use fbGetDisplay() and the like in order to connect a framebuffer index which could then be used as the NativeDisplay for EGL.  However I can not seem to find a library with the fb* symbols in the yocto build.  I was wondering is anyone has used OpenGL ES 2.0 with fbdev and yocto?

Thanks,

Brian

Labels (3)
7 Replies

159 Views
grim
Contributor III

Thank you gentlemen.

I'll give that a shot!

0 Kudos

159 Views
OtavioSalvador
Senior Contributor II

You must change the distro features to accomplish this.

Add:

DISTRO_FEATURES_remove = "wayland x11"

To your local.conf file. This is for playing with it, for products it is advisable to make a custom distribution for it.

159 Views
grim
Contributor III

Thanks Mr Salvador!

That did the trick for me.

0 Kudos

159 Views
OtavioSalvador
Senior Contributor II

So please mark it accordingly.    

0 Kudos

159 Views
grim
Contributor III

I thought that only the thread creator could do that.

0 Kudos

159 Views
grim
Contributor III

I'm in the process of figuring out how to do this as well.

Have you found a solution?

Hopefully I can make some headway on this sometime this week.

0 Kudos

159 Views
huib-janimbens
Contributor II

I copied one of the files at Index of /buildsources/g/gpu-viv-bin-mx6q and manually copied the fb libraries to /usr/lib. The precise files to copy and links to make depend on the version you use.

I now have both OpenGL ES 2.0 and h264 decoding running on fb.