example CSF triggers syntax error

Showing results for 
Show  only  | Search instead for 
Did you mean: 

example CSF triggers syntax error

Contributor IV

Hello, I copied the csf example file from this document https://www.nxp.com/docs/en/application-note/AN4581.pdf at page 35, G.3. Signing the image , calling it csf-uboot.

I placed the file in a folder called "cst" , together with the cst binary executable. This folder is a subfolder of "release/" folder, so at same level as /keys subfolder.

I run the cst binary with command "./cst --o csf-uboot.bin --i csf-uboot" ( It is cst 3.3 )

It raises error 

error: line 11: syntax error
Undefined error

Line 11 is : 

File = “../crts/SRK_1_2_3_4_table.bin”

I verified and the file SRK_1_2_3_4_table.bin is there, in the folder crts.

Why is this error raised ?

Here are the first 12 lines of the csf-uboot file :

#Illustrative Command Sequence File Description
Version = 4.2
Hash Algorithm = sha256
Engine = ANY
Engine Configuration = 0
Certificate Format = X509
Signature Format = CMS

[Install SRK]
File = “../crts/SRK_1_2_3_4_table.bin”
Source index = 0
# Index of the key location in the SRK table to be installed


thank you

Tags (3)
0 Kudos
3 Replies

Contributor IV

I moved cst executable and csf-uboot ( the csf file copied from the document said above ) to crts folder; I moved there also the binary file to sign.

I updated all of the paths in the csf-uboot file so that they point to local folder, so I have now everything needed in the crts folder. 

When I run the command to execute t now raises a different error : 

 ./cst --o csf-uboot.bin --i csf-uboot
realloc(): invalid pointer
Aborted (core dumped )

Unfortunately I cannot see what this invalid pointer refers to.

Do you know what is wrong ? I am using latest cst 3.3.0.

0 Kudos

Contributor V


    I'm currently trying to sign the i.MX 8M Mini and got the same error as you've mentioned here. I've already posted a query in NXP forum (Signing error in i.MX8M Mini - FIT Image ) yet no success as of now.

    I would like to hear from you hoping you've solved the problem. Any inputs would be much appreciated.

Thanks in advance.

0 Kudos

NXP Employee
NXP Employee


 Use documentation and examples in U-boot.


habv4\imx\doc - uboot-imx - i.MX U-Boot 


Have a great day,





- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored


Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos