RT1052

cancel
Showing results for 
Search instead for 
Did you mean: 

RT1052

518 Views
Zz1han
Contributor I

使用RT1176开发板(B2版)烧录程序,用JLINK进行烧录,烧录程序失败,用JFLASH进行连接主控芯片,能连上,但是擦除flash失败,会弹出如图1的提示框。使用NXP-MCUBootUtility刷新flash,调整好拨码之后上电,在connect的时候会弹出如图2的提示框,然后再reset也是反复。微信图片_20210910170832.png微信图片_20210910170729.png

0 Kudos
17 Replies

501 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
感谢回复。
从我们的经验来说,出现这种问题,主要是更硬件有关,比如电压选择跳冒位置不对,电压芯片坏了等,我建议你先用万能表检查一下EVK开发板。
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

497 Views
Zz1han
Contributor I

你好,对于RT1176和RT1052两块无法烧录的板子,我们对硬件做了详细的排查,测试每个接口的电压,发现SDRAM的片选引脚始终没有电压,由于R90也没有焊接,那供电就是来自主控芯片,鉴于主控芯片我们刚刚换过,那问题是不是就处在SDRAM上呢?望详解。(两块板子都是这样的问题)5c6f0dda80d14d8e2087328fa65c098.png

0 Kudos

491 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,

你回复中所说的”没有电压“具体表现是什么?

在我看来,进入Serial Download应该跟SDRAM是无关的。

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

486 Views
Zz1han
Contributor I

完整步骤是这样的:板子从朋友那边借过来让我们看看是否能用,第一次拿回来我们测试每个通讯端口,只有第一次烧录HELLO WORLD成功了,其余例程都没有跑进主函数,然后我们用JFLASH能连上主控芯片,但是无法擦除flash,然后我们测试了电压,qspiflash上的电压全部正确(那时候没有测SDRAM),后面更换了QSPIFLASH,依然无法烧录,使用NXP-MCUBootUtility-master,会出现提示已经进入flashloader模式,但是无法分配外部存储,然后再测试所有模块电压,发现SDRAM的电压使能脚电压一直为0,R因为90断开,所以SDRAM电压来自主控芯片,但是主控芯片也更换过,也能连上JFLASH,所以主控芯片肯定没问题,然后至于使用其他接口使用NXP-MCUBootUtility-master,会检测不到接口。

0 Kudos

474 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
感谢回复。
根据你的测试结果,我也用万能表测试了一下我板子上的SDRAM的CS脚,测试结果如下:
1)运行evkmimxrt1170_hello_world_demo_cm7工程(会使用SDRAM),则SEMC_CS0一般表现为3.3 V的高电平。
2)运行evkmimxrt1170_iled_blinky_cm7工程(没有使用SDRAM),则SEMC_CS0表现为0 V的低电平。
所以你测试发现SEMC_CS0为0 V的低电平,这是正常现象.
我看你在使用NXP-MCUBootUtility时都是选择的USB,请问有试过UART口来连接板子吗?
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

471 Views
Zz1han
Contributor I

使用串口也会有同样的情况。如图。94a35c20205c223e6ead9412442eb2f.pngd8cfea301b11f515bac23c097edd776.png

0 Kudos

466 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
感谢回复!
从屏幕截图来看,你选择的是RT500,你上面说的开发板是RT1170的。
我建议你重新连一下吧。

jeremyzhou_0-1631760124957.png


Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

461 Views
Zz1han
Contributor I

你好,上次是操作失误,这次都选择无误,仍然存在问题。如图。88cfb3ce0b19808bcf0d43be5a38436.png8282c17caeb56248755e37f0e5ce365.png

0 Kudos

458 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
根据错误提示,配置QSPI出错,可能是你选择的QSPI与板子上的真正的QSPI型号不匹配,还有你能否分享一下NXP-MCUBootUtility工具Doc界面里的log记录,这里面也会有错误报告提示。
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

451 Views
Zz1han
Contributor I

你好。

      我们更换的flash肯定是和官方原理图里型号都一致的(IS25WP128-JBLE),NXP-MCUBootUtility-master里面的FLASH选择也选择了对应的,如图。另外,你所需要的Doc里的log记录是指的这个吗,如果不是,还希望说一下具体在哪里找。a82f6af7015ef0280539e12f299b56f.png23bfb2c7775090bc0ebc63eb89ffded.png

0 Kudos

443 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
1) 你所需要的Doc里的log记录是指的这个吗,如果不是,还希望说一下具体在哪里找。
-- 每次打开NXP-MCUBootUtility时,都会同时打开一个Doc界面(如下图所示),里面记录每次在NXP-MCUBootUtility主界面操作的命令执行记录和对应执行结果。

jeremyzhou_0-1631858290180.png


还有,你手上还有多余的板子吗,可以在硬件检查时作一个参考。

Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

438 Views
Zz1han
Contributor I

你好

       这块坏掉的板子Doc的log如下图。对于硬件上的排查,我们也有另一块好的板子作为对照,电压上面测下来是没有问题。另外,这块板子拿回来的时候,J53的2脚是和C59是跳线相连的,我不知道这是否有影响,因为正常使用的那块板子没有连,我们使用的时候就也断开了。FYI.4ec205e802ed3cb4bee449eab6be1ba.png9bc59d80705a2a499f1855a16600293.png1531b89e4a290cff20fa7fe5671198a.pngadf24d62defc2a038cb10c81b0242f3.png

0 Kudos

419 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
从错误提示来看,MCU配置QSPI过程中有错误,MCU看起来好像是好的,对照原理图,跳线应该没有影响,但是我觉得你还是断开后也测试一下吧,还有你最好跟你那朋友确认一下还有哪些硬件改动。
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

413 Views
Zz1han
Contributor I

你好

       经过确认,板子上除了那个跳线,其余没有任何硬件上的改动。关于NXP-MCUBootUtility-master上操作记录上说明是QSPI的配置出现了问题,可否具体要怎么样配置。另外,关于NXP-MCUBootUtility-master,有没有一些更加具体的使用说明,因为目前我们了解这个工具更多的也是靠痞子衡发布的用户指南。785cf89c269db1d825079aba629ab2c.png

0 Kudos

388 Views
jeremyzhou
NXP TechSupport
NXP TechSupport
Hi, 感谢回复。 对于RT1170开发板,NXP-MCUBootUtility-master上的操作不太需要自己额外配置的,选择默认就好,你可以把好的RT1170开发板中的IS25WP128移到坏的板子再测试一下。 如果还是不行的,你可以联系当地代理商FAE或者恩智浦FAE进行现场测试。 Have a great day. TIC ------------------------------------------------------------------------------- Note: - If this post answers your question, please click the "Mark Correct" button. Thank you! - We are following threads for 7 weeks after the last post, later replies are ignored Please open a new thread and refer to the closed one, if you have a related question at a later point in time. -------------------------------------------------------------------------------
0 Kudos

510 Views
jeremyzhou
NXP TechSupport
NXP TechSupport

Hi,
非常感谢使用NXP产品,很高兴为你提供技术支持!
请介绍一下在出现上述问题之前,你对EVK开发板做了哪些测试?
我建议你使用UART接口与NXP-MCUBootUtility再从新连接一下,如何还是连接失败,请分享一下log记录。
Have a great day,
TIC

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

506 Views
Zz1han
Contributor I

这块1176的开发板是从朋友那里拿过来的,我们测试几个通讯端口能否正常使用,就烧录一些例程进去,只有第一次HELLO WORLD烧录能跑进主函数,后面再烧录其他程序也都无法烧录成功,测试电压都正确,后面也更换了新的QSPIFLASH,仍然没法烧录程序,使用NXP-MCUBootUtility,连接J9,点击connect,会弹出如图1提示框,图2为操作记录,换用其他会无法检测到USB接口,如图3.0276565cd3873a43a886635488e9d34.pngc0aee777d4f7eceaf768c0849a1600b.png68ff0875e21592af9534665ed1657de.png

 

0 Kudos