LTIB on i.MX25 PDK broken...

cancel
Showing results for 
Search instead for 
Did you mean: 

LTIB on i.MX25 PDK broken...

776 Views
jppoulin
Contributor III

Hello,

After purchasing a i.MX25 PDK spending two full days following directions and numerous posts on how to fix LTIB for i.MX25 I remain stuck on numerous issues:

- I can't compile LTIB on numerous issues such as lkc (LTIB install -- Failed building lkc), wget and numerous other packages.

- ATK won't run on Windows 7 - 64-bit

I am looking for alternative to aging / broken LTIB.  Directions nearly always appear to apply to other newer boards and don't work on my i.MX25.

- Has anyone succeeded in getting Yocto or Open Embedded running on i.MX25 PDK?

- If not, does anyone have a virtual machine properly configured to use ltib for MX25 PDK board?

I have gotten several previous boards running previously (MX233, MX6, MX21, MX31) but this one escapes me.

Thanks for any help you can offer... grasping at straws.

  Jean-Pierre

Labels (3)
5 Replies

195 Views
fabio_estevam
NXP Employee
NXP Employee

Hi Jean-Pierre,

It would be nice to add mx25pdk support into Yocto.

mx25pdk is already supported by mainline U-boot and mainline kernel, so adding it to Yocto would be simple.

Regards,

Fabio Estevam

195 Views
jppoulin
Contributor III

Hi Fabio, thanks for that interesting post.

I would be interested in the effort to bring Yocto to the MX25.  Certainly with testing and possibly with development.

Could you give me a heads-up on what the procedure might involve?  How would I get started?

Many thanks!

0 Kudos

195 Views
fabio_estevam
NXP Employee
NXP Employee

Hi Jean-Pierre,

You need to prepare a patch for adding mx25pdk support into meta-fsl-arm.

Here is an example on how to add a new board:

http://patches.openembedded.org/patch/82199/

In this example Daiane added support for mx6 riotboard into meta-fsl-arm-extra. (The -extra means that this board is from third-party. The FSL boards go to meta-fsl-arm instead).

If you have questions about this, then I suggest you post them to meta-fsl-arm mailing list.

Regards,

Fabio Estevam

195 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Jean-Pierre

one can try install Ubuntu 9.04 (Freescale ltib was tested on that release)

Ubuntu 9.04 (Jaunty Jackalope)

L2.6.31_09.12.00_SDK_SOURCE : Linux 2.6.31 Source Code Files 2009.12

Release support i.MX23, i.MX25

Useful reading for ltib build :

http://cache.freescale.com/files/dsp/doc/app_note/AN3875.pdf

http://www.eetasia.com/STATIC/PDF/201004/EEOL_2010APR29_CTRLD_AN_01.pdf?SOURCES=DOWNLOAD

Regarding yocto suggest post to meta-fsl-arm mailing list

https://lists.yoctoproject.org/listinfo/meta-freescale

will i.MX25 support the latest Linux kenel 3.?

linux/imx25-pdk.dts at master · torvalds/linux · GitHub

Yes, ATK (mean USB connection) will not run on Windows 7 - 64-bit,

probably you can try UART ? Below link for i.MX25 MFG Tool, though

I believe, it will work only on Windows 7 - 32-bit.

How to create your own Mfgtool firwmare

Best regards

igor

195 Views
jppoulin
Contributor III

Hi Igor, many thanks for these useful links and prompt response... gets me unstuck!

I'll retry everything on Jaunty.

I'm a bit surprised ATK won't run on Win7/64... hardly any machines run 32-bit OS now.  Are you aware of efforts to fix ATK to run on most machines?

Many thanks!  Will report when I've tried all this. :smileyhappy:

   Jean-Pierre

0 Kudos