BSP L5.15.5 Compile Issue

cancel
Showing results for 
Search instead for 
Did you mean: 

BSP L5.15.5 Compile Issue

Jump to solution
2,248 Views
weilly_li
Contributor IV

Hi, Guys

I got some trouble when I tried to build yocto BSP L5.15.5.
It is about qt-base.bb package comiple error, have someone ever meet the same things ?

my step on ubuntu 20.04 :
       $ mkdir <Yocto Project>
       $ cd <Yocto Project>
       $ repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-honister -m imx-              5.15.5-1.0.0.xml
       $ repo sync
       $ EULA=1 MACHINE=imx8mpevk DISTRO=fsl-imx-xwayland
       $ source ./imx-setup-release.sh -b buildxwayland
       $ bitbake imx-image-full

error log as :

qtbase.png

 

0 Kudos
1 Solution
2,046 Views
HME15769
Contributor II

Hi, @weilly_li 

Please check the log file when "do_install" process failed.

(location: <your_env>/tmp/work/cortexa53-crypto-poky-linux/onnxruntime/1.10.0-r0/tmp/log.do_install.xxxxx)

 

I had same issue because onnxruntime from "onnxruntime-imx" repository contained an unsafe repository.

This error information is listed on my "log.do_install.xxxxx" file.

In my case, the solution to this issue is "git config --global --add safe.directory <unsafe repo's directory>" command.

 (This issue probably occurred recently. https://github.com/actions/checkout/issues/760 )

 

View solution in original post

13 Replies
2,103 Views
josephzhou1
Contributor V

hi i saw you first used  " fsl-yocto-8mp-5-15 " , suddenly

u changed to "imx-yocto-bsp-L5-15-5" 

sometimes this issue caused by other files in yocto between two builds two folders :

 

 

i means can you totally delete all old files , and create new folder ,open new terminal , new repo sync and build it again , shld be ok.

 

 

Best Regards,
Joseph Zhou Jianhui / Senior Embedded Software Engineer, Singapore
0 Kudos
2,241 Views
Qmiller
NXP Employee
NXP Employee

Please try to clean this project and redownload it.

0 Kudos
2,227 Views
weilly_li
Contributor IV

Hi, @Qmiller 

      I tried clean this project and redownload it ! this is same error !!

      command as :

         bitbake -f -c clean qtbase
         bitbake -f -c build qtbase

         or

         bitbake -f -c clean nativesdk-qtbase
         bitbake -f -c build nativesdk-qtbase

      Which one need to fix ? Thank
      

0 Kudos
2,218 Views
Qmiller
NXP Employee
NXP Employee

Try to delete all files and redownload yocto project, sometimes this issue caused by other files in yocto

0 Kudos
2,202 Views
weilly_li
Contributor IV

Hi, @Qmiller 

       I rebuild all yocto project , still same issue all time.

       Did you build yocto bsp L 5.15.5 ?  I offer u my log , please help me check it ...

       Thank You
       
       

      

0 Kudos
2,193 Views
Qmiller
NXP Employee
NXP Employee

NXP has tested this version before release.

I didn't see this issue, even in WSL2.

Did you install all host packages on Ubuntu20.04?

0 Kudos
2,185 Views
weilly_li
Contributor IV

hi, @Qmiller 

Thank You for help , I has build done about qtbase.

I found this Issue at VMWare , so I run "bitbake qtbase" after modify virtual RAM and CPUs . Now BSP task achice 21 %

I'll note here after anything problem , Thank You

ref : https://bugreports.qt.io/browse/QTQAINFRA-4669

0 Kudos
2,170 Views
weilly_li
Contributor IV

Hi, @Qmiller 

        Now,  I have a troblem about ONNXRuntime do_fetch Issue.

        Please tell me what's next ? I will apprecitate you !! thank you

         onnxruntime.PNG

        

0 Kudos
2,168 Views
HME15769
Contributor II

protobuf git link is incorrect in the 2nd error line. "master" branch is not exist in protobuf repository.

https://community.nxp.com/t5/i-MX-Processors/Build-of-onxxruntime-native-in-imx-image-full-for-IMX8M...

2,154 Views
weilly_li
Contributor IV

. Hi, @HME15769 

      that's very power information !!  I fetched successfully onnxruntime !! 
      thank you so much !!

 

 

0 Kudos
2,108 Views
weilly_li
Contributor IV

Hi, @HME15769 and @Qmiller 

       I still fail as onnx runtime comiple....

0 Kudos
2,047 Views
HME15769
Contributor II

Hi, @weilly_li 

Please check the log file when "do_install" process failed.

(location: <your_env>/tmp/work/cortexa53-crypto-poky-linux/onnxruntime/1.10.0-r0/tmp/log.do_install.xxxxx)

 

I had same issue because onnxruntime from "onnxruntime-imx" repository contained an unsafe repository.

This error information is listed on my "log.do_install.xxxxx" file.

In my case, the solution to this issue is "git config --global --add safe.directory <unsafe repo's directory>" command.

 (This issue probably occurred recently. https://github.com/actions/checkout/issues/760 )

 

1,991 Views
weilly_li
Contributor IV

Hi, @HME15769

      Your solution is great detail !!

      I had compile finish on yocto bsp L5.15.5

      so appreciate your help !! Thank !! 

0 Kudos