Android 6 patch for WL1831MOD wifi/BT chip

cancel
Showing results for 
Search instead for 
Did you mean: 

Android 6 patch for WL1831MOD wifi/BT chip

455 Views
aravinthkumarja
Senior Contributor II

Dear All,

I have followed below link (Android 5 patch) to integrate wl1831 into Android 6 in imx6 sabresd board. When I'm testing it is working with Android 5 Mobile device. But it was not working properly with Android 6 mobiles. Some of events not receiving properly.

So can you please provide me the respective patch and firmware for Android 6. 

Android 5 patch reference link:

processors.wiki.ti.com/.../WL18xx_First_Time_Getting_Started_Guide_(IMX6)

Regards,

Aravinth

0 Kudos
5 Replies

87 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi aravinthkumar

as Android 6 is based on L4.1.15 kernel, one can look at drivers provided

for that kernel on

WiLink8 Linux Getting Started Guide Android - Texas Instruments Wiki 

or port it using

http://www.jorjin.com/upload/1484543611.pdf 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

87 Views
aravinthkumarja
Senior Contributor II

Hi igor,

My Android version :6.0.1

Kernel version: 3.14.52

Regards,

Aravinth

0 Kudos

87 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Aravinth

for kernel version: 3.14.52 please follow p.2 document

http://www.jorjin.com/upload/1484543611.pdf

Best regards
igor

0 Kudos

87 Views
aravinthkumarja
Senior Contributor II

Hi igor,

Your reference document for yocto bsp. I want it for Android BSP.

Regards,

Aravinth

0 Kudos

87 Views
BiyongSUN
NXP Employee
NXP Employee

You need to check with the vendor for wl1831. Because the Android is not that simple like Linux.

It including the framework code changes.The vendor for wl1831 will ask you about the detailed version of Android you are using, they will provide the SDK.  

0 Kudos