4.9 kernel for imx6slevk

cancel
Showing results for 
Search instead for 
Did you mean: 

4.9 kernel for imx6slevk

807 Views
susangracerapak
Contributor II

How to build latest 4.9 kernel for the Imx6slevk board using Freescale yocto project?

Can anyone share the documents?

Regards

Susan

Labels (1)
0 Kudos
4 Replies

111 Views
susangracerapak
Contributor II

Hi gusarambula,

Thanks for the update.

Regards

Susan

0 Kudos

111 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Susangrace Rapaka,

There is a recipe in place for 4.9 on the latest Community BSP for the Morty branch of the Yocto Project. However, it’s not a complete recipe and as I imagined I couldn’t bake it.

I added the following on the conf/local.conf file and tried baking linux-fslc-imx

PREFERRED_VERSION_linux-fslc-imx = "4.9"

 

But I got the following warnings:

NOTE: preferred version 4.9 of linux-fslc-imx not available (for item linux-fslc-imx)

NOTE: versions of linux-fslc-imx available: 4.1-2.0.x+gitAUTOINC+ee67fc7e07

NOTE: Resolving any missing task queue dependencies

NOTE: preferred version 4.9 of linux-fslc-imx not available (for item kernel-base)

NOTE: versions of linux-fslc-imx available: 4.1-2.0.x+gitAUTOINC+ee67fc7e07

NOTE: preferred version 4.9 of linux-fslc-imx not available (for item kernel-image-zimage)

NOTE: versions of linux-fslc-imx available: 4.1-2.0.x+gitAUTOINC+ee67fc7e07

NOTE: preferred version 4.9 of linux-fslc-imx not available (for item kernel-image)

NOTE: versions of linux-fslc-imx available: 4.1-2.0.x+gitAUTOINC+ee67fc7e07

Currently the supported kernel for both the BSP release and Community BSP is 4.X (verion varies depending on the BSP). I would recommend using these kernels unless you absolutely need a feature from kernel 4.9 that’s not available on previous versions, in which case you would need to adapt the mainline kernel to work for your MACHINE.

I hope this information helps!

Regards,

0 Kudos

111 Views
susangracerapak
Contributor II

Hi gusarambula,

Thanks for your information. I have tried the same earlier but it wasn't working.

I have brought up the latest kernel 4.1 successfully but, I need 4.9 now. Do you have any idea which Machine has the build with 4.9 kernel[Imx platfrom]?

Regards

Susan

0 Kudos

111 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Susan,

From what I see there are no machines using Kernel 4.9 on the Community BSP, which makes sense as it's too recent. I think you would need to work on the mainline kernel and adapt it for the i.MX family, which would be a lot of work.

Regards,

0 Kudos