Setup QT Creator with Yocto Build

Showing results for 
Search instead for 
Did you mean: 

Setup QT Creator with Yocto Build

No ratings

Setup QT Creator with Yocto Build

bitbaked meta-toolchain-qt

Install it  with


Download Qtcreator from here

and Install it to Your home directory

edit the bin/

source /opt/poky/1.4.1/environment-setup-armv7a-vfp-neon-poky-linux-gnueabi
#! /bin/sh

makeAbsolute() {
    case $1 in
            # already absolute, return it
            echo "$1"
            # relative, prepend $2 made absolute
            echo `makeAbsolute "$2" "$PWD"`/"$1" | sed 's,/\.$,,'


To do it before "#! /bin/sh" is IMPORTANT!!!!

In QtCreator i set

Compiler as


Qt version as



sysroot as


Put them in a Kit

For connection to Your Board click on  Device  --->    Manage

Build a new project

and add some to the .pro file

Building the image for Your Board:


EXTRA_IMAGE_FEATURES = "debug-tweaks ssh-server-openssh" to Your localconfig

bitbake core-image-sato-sdk

set a password to root  via

ssh root@[boardip]


test connection via

sftp  root@[boardip]

start qtcreator


Message was edited by: Joerg Boge

Good Video to get more Information about Programming are this

Beaglebone: LCD Touchscreen GUI Applications for Embedded Linux - YouTube

Beaglebone: Qt Creator for C++ ARM Embedded Linux Development - YouTube

Beaglebone: Example Qt Embedded Linux Application - YouTube

It is for Beagelbone but for programming Qt it is a good start.

Dieses Dokument wurde aus folgender Diskussion erzeugt: Setup QT Creator with Yocto Build


Hi there!

Starting the ./ from the Terminal works fine for me but isn't very convenient I think.

Why isn't it possible to set all the env-Variables directly in the build settings of Qt Creator?

Setting the environment variables (which is everyhing what the environment-setup-... does at the moment) directly in Qt Creator (Projects->Build Settings->Build Environment) doesn't work - does anyone know why?

The other way around for me would be to create a .desktop for a quick execution of the .sh from the Desktop/Starter Menu.

But there is another problem with creating a .desktop file on Ubuntu: It doesn't find the environment-setup-... (1: /mypath/ source: not found) on starting with the .desktop-file - is there something wrong? As already set: Executing it directly from the terminal works flawlessly.

qtcreator.desktop (in same directory as

[Desktop Entry]


Name=Qt Creator







Any other ideas in improving this step and working around the "problem" of starting the qtcreator from the terminal?

Me again :smileywink:

Maybe we should also mention to use bitbaked meta-toolchain-qte to use e.g. the QWS Qt Window Server without the need for X11.

What do you think?

Best regards


Hello Florin,

You should give it a try. I build fsl-image-gui with that local.conf features:


DISTRO ?= 'poky'

PACKAGE_CLASSES ?= "package_rpm"

EXTRA_IMAGE_FEATURES = "debug-tweaks ssh-server-openssh"

CORE_IMAGE_EXTRA_INSTALL_append = "openssh-sftp-server "

TOOLCHAIN_HOST_TASK_append = " nativesdk-python-subprocess" 

works fine. debugging i did'nt test till now

So with this setup you were able use QWS without X11? Because I also tried successfully the fsl-image-gui. But then it uses X11 instead of directfb for rendering the Qt-Application.

For performance and faster boot I wanted to get rid of X11.

And what I thought is, that I have to use the meta-toolchain-qte instead of meta-toolchain-qt to compile my Qt-App the right way - if that is the case we should mention it in this DOC.

I am following all the steps mentioned above, however after I  boot the Nitrogen 6x  board, I am unable to connect through sftp.

It has the following error, can someone please help me out

sftp root@

root@'s password:

sh: /usr/lib/openssh/sftp-server: No such file or directory

Connection closed


When I run "bitbaked meta-toolchain-qt", I meet a problem.

Missing or unbuildable dependency chain was ["meta-toolchain-qt","packagegroup-qt-toolchain-target","qt4-mkspecs","virtual/libx11"]

Why it is?

Version history
Revision #:
1 of 1
Last update:
‎07-30-2013 07:33 AM
Updated by: