Enable WIFI on Ubuntu 22.04 and Linux BSPs in iMX8 Family

Showing results for 
Search instead for 
Did you mean: 

Enable WIFI on Ubuntu 22.04 and Linux BSPs in iMX8 Family

100% helpful (1/1)

Enable WIFI on Ubuntu 22.04 and Linux BSPs in iMX8 Family

Installing the new release (Ubuntu 22.04) was detected some NXP boards as iMX8MNEVK, iMX8MM-EVK, iMX8MP-EVK and iMX8ULP-EVK had an issue with the WIFI
module that basically it does not initialize at boot.

Remember, the supported WIFI modules in Ubuntu 22.04 in the EVKs are the following:

      • NXP 88W8987
      • NXP 88W9098
      • NXP 88W8997
      • NXP IW416
      • NXP 88W8801
      • NXP IW612

To initialize the WIFI module of NXP EVKs in Ubuntu 22.04 you can set the following
command in console:


sudo modprobe moal mod_para=nxp/wifi_mod_para.conf


That command find the correct driver for our WIFI module and then initialize it, but this
only works when Ubuntu is working and if you reset the EVK you need to set the command


The definitive solution is create a custom startup script as a service:


Step 1: Go to etc/systemd/system


cd etc/systemd/system


Step 2: In this directory create a new file with the name of your preference but the
extension must be .service.

You can do it with nano or vim:

sudo nano 


sudo vim


The file must contain:

Description=”Wifi Start”
ExecStart=sudo modprobe moal mod_para=nxp/wifi_mod_para.conf


Now save the file, in my case the name was wifi_start.service.


Step 3: Now we need to enable the script in the startup/boot sequence following the

sudo systemctl enable wifi_start.service


Remember in wifi_start.service is the name as you saved your file.


Finally, each time you boot your board, the WIFI module will initialize automatically.


Boards tested:
iMX8MN (With WIFI module NXP 88W8987)
iMX8MM (With WIFI module NXP 88W8987)
iMX8MP (With WIFI module NXP 88W8997)
iMX8ULP (With WIFI module NXP IW416)



Hi everyone,

I'm having issues in with the 8MNANOD4-EVK and the v6.1.1 Linux Distro version. I go through module activation with:


modprobe moal mod_para=nxp/wifi_mod_para.conf

After this, dmesg show:

Screenshot from 2023-06-19 17-00-56.png

Seems driver exists but its not  as verbose as i would like. Unfortunately, interface its not appearing

Screenshot from 2023-06-19 17-03-16.png

I tried to set the wifi network credentials in wpa_supplicant.conf and then updated with the command

wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf -D nl80211

But seems not to brings up the interface



I tried this process with full and multimedia image in the application images provided. I also try v5-15.71 and v5.10.52, same results as above.

Someone have any idea what could be happening? Thanks!

Version history
Last update:
‎06-07-2023 06:50 AM
Updated by: