Switch T1024RDB NOR Flash From Current Bank To Alternate Bank

cancel
Showing results for 
Search instead for 
Did you mean: 

Switch T1024RDB NOR Flash From Current Bank To Alternate Bank

Jump to solution
978 Views
gokhangocmen94
Contributor II

Hello everyone,

I have a T1024RDB. In U-Boot console, I tried to upload a binary file (its name is "U-Boot.bin" that storages in SDK v1.7.)

Then, I reset T1024RDB and I can't see any message in serial port console. I guess this U-Boot.bin file has not equal functionality like original U-Boot that loaded in NOR Flash.

For now, I don't have any CodeWarrior TAP or any flash programmer. When i look at the NOR Flash memory map, I see these values:

0xeff40000

0xefffffff

U-Boot (current bank)

768 KB

0xeff20000

0xeff3ffff

U-Boot env (current bank)

128 KB

0xebf40000

0xebffffff

U-Boot (alternate bank)

768 KB

0xebf20000

0xebf3ffff

U-Boot env (alternate bank)

128 KB

Can I change my start address from current bank to alternate bank without using CodeWarrior TAP or Flash Programmer? If I switch it, Will be My problem solved?

Thanks.

Labels (1)
1 Solution
850 Views
ufedor
NXP TechSupport
NXP TechSupport

You have to set SW3[5-7] = OFF ON ON for virtual bank 4

Current setting is ON ON ON

View solution in original post

9 Replies
850 Views
ufedor
NXP TechSupport
NXP TechSupport

Refer to the QorIQ T1024 Reference Design Board Quick Start, 7.3 Switch detailed description:

T1024_vbank.jpg

850 Views
gokhangocmen94
Contributor II

On the hardware, There are SW3 swithces numbered as 1-8. By default, Value of These SW3[6-8] switches was '110'.

Although I switched them '000' and '100', I couldn't see any message in my serial port console.

Is U-Boot loaded in the alternate bank?

0 Kudos
850 Views
ufedor
NXP TechSupport
NXP TechSupport

You have to set SW3[5-7] = OFF ON ON for virtual bank 4

0 Kudos
850 Views
gokhangocmen94
Contributor II

I tried it, but there was not any change. I have set these switches on the hardware, Is it enough?

0 Kudos
850 Views
ufedor
NXP TechSupport
NXP TechSupport

> I have set these switches on the hardware

What do you mean?

Please provide the board SWs screenshot.

0 Kudos
850 Views
gokhangocmen94
Contributor II

20200821_144551.jpg

I don't have any SWs to provide screenshot.

I loaded a .bin file as Bootloader via TFTP. After I had loaded it, U-Boot was broken.

According to my guess, If I alter NOR flash bank as alternate bank, maybe U-Boot will be fixed. Is this possible without using CodeWarrior TAP?

0 Kudos
851 Views
ufedor
NXP TechSupport
NXP TechSupport

You have to set SW3[5-7] = OFF ON ON for virtual bank 4

Current setting is ON ON ON

View solution in original post

850 Views
gokhangocmen94
Contributor II

Yes, I tried all combinations you said. After I had tried, I changed them as default values.

However, I tried again it, it works. But to work, I have to push reset button.

For example, I switched SW3[5-7] as OFF ON ON. And then, If I push power button, It doesn't work.

If I press the reset button after I press the power button, It works. What do you think of this?

Edit: Because of JTAG Device, I have to reset T1024RDB.

Thanks.

0 Kudos
850 Views
burakorcun_ozka
Contributor III

Gokhan,

When u-boot uploaded into the board prints startup logs, you can see which bank is active at that time.

According to NOR memory mapping you wrote, you can upload u-boot.bin for the board to alternative bank, not current bank. Then, regardless of changing switch to activate alternative bank, you can use 'cpld reset altbank' command to start  the board from alternative bank.