MXP10DP pressure sensor problems.

cancel
Showing results for 
Search instead for 
Did you mean: 

MXP10DP pressure sensor problems.

Jump to solution
1,080 Views
CyrusH
Contributor I

Hello, we recently got a MXP10DP pressure sensor, and the manual seems to say that the output voltage should range from 0-35mV. Our sensor is showing a 1.5V output while in the air, where the pressure difference should be 0, so I would expect the output voltage to be 0 or at least close to 0. Our setup has ground plugged into pin 1, sensor wire in pin 2, and voltage source(3V) in pin 3. Please help if you know what our problem is, or how to fix this. Thank you.

Labels (1)
0 Kudos
1 Solution
1,072 Views
TomasVaverka
NXP TechSupport
NXP TechSupport

Hello Cyrus,

I suppose you are measuring the voltage on +Vout (pin 2) with respect to GND.

However, this is not correct, you should measure the differential voltage between +Vout (pin 2) and -Vout (pin 4).

At the maximum differential pressure of 10 kPa, the differential output voltage between +Vout or -Vout should be around 55 mV @ 3V Vs.

Best regards,

Tomas

View solution in original post

6 Replies
1,073 Views
TomasVaverka
NXP TechSupport
NXP TechSupport

Hello Cyrus,

I suppose you are measuring the voltage on +Vout (pin 2) with respect to GND.

However, this is not correct, you should measure the differential voltage between +Vout (pin 2) and -Vout (pin 4).

At the maximum differential pressure of 10 kPa, the differential output voltage between +Vout or -Vout should be around 55 mV @ 3V Vs.

Best regards,

Tomas

1,051 Views
bonjiman
Contributor I

Hi Tomas, 

I had a similar issue with the MPX2010GP yesterday.  At ambient temperature/pressure, the sensor had a constant DC output at a level of ~1V, and I was measuring this voltage across Vo+ and Vo- rather than referencing to GND as you suggest.  If these sensors require some external circuitry to properly function, this information should be in the datasheet.

Can you suggest any other reasons these sensors may be failing? 

0 Kudos
1,022 Views
TomasVaverka
NXP TechSupport
NXP TechSupport

Hello Bonjiman,

I have not heard about a similar problem before. Each MPX2010GP pressure sensor is laser trimmed for full scale output, offset and temperature compensation.

Figure 2 shows the differential output voltage of the MPX2010GP at +25°C and 10V supply voltage.

Figure 2.JPG

Are you using op amps on the outputs to amplify the differential output voltage? You can find some information about that e.g. in the old AN1318, but my recommendation would be using a single chip solution such as the INA122 instrumentation amplifier.

Best regards,

Tomas

0 Kudos
977 Views
bonjiman
Contributor I

Tomas,

I'm trying this again with a different sensor (the MPX2300DT1), and I am having similar issues.  I have pin 1 connected to supply (6V), pins 2 and 3 are connected to one channel of my scope, and then pin 4 is connected to GND.  

When I energize the circuit in room temperature and atmospheric pressure, I expect a constant signal at a low offset of close to 0-mV because there should be no pressure differential across the bridge.  However, what I get is a signal at ~500-mV that stays still no matter how much I try to apply pressure to the sensor.

I have checked and re-checked my wiring a million times, but I'm not sure where I'm messing up such a simple circuit.

I have no op-amps or any active components at the output of the sensor.  The outputs go straight into the scope.

0 Kudos
974 Views
bonjiman
Contributor I

Tomas,

On further inspection, I think I do see the variations in the differential signal.  However, I'm wondering if you have any input about the huge offset I'm seeing at the output?  The sensor says it is rated to limit offset to within 1 mV or so, yet the output is as high as 500-mV with no pressure differential across the sensor.

0 Kudos
943 Views
TomasVaverka
NXP TechSupport
NXP TechSupport

Hello Bonjiman,

I have no idea what could be the root cause of this unexpectedly high offset voltage.

Are you really measuring the differential voltage between pins Vout+ (pin 2) and Vout- (pin 3)?

What is the supply current in this case?

How many MPX2300DT1 sensors have you tested so far?

Best regards,

Tomas

0 Kudos