SE050-PLUG-TRUST-MW compilation issue

cancel
Showing results for 
Search instead for 
Did you mean: 

SE050-PLUG-TRUST-MW compilation issue

Jump to solution
138 Views
Contributor I

We are using imx6solox conected to SE050 using I2C .

I am facing compilation  issue like this

===================

cc1: error: '-Wformat-security' ignored without '-Wformat' [-Werror=format-security]
| cc1: some warnings being treated as errors
| demos/apdu_player/CMakeFiles/apdu_player_demo.dir/build.make:62: recipe for target 'demos/apdu_player/CMakeFiles/apdu_player_demo.dir/apdu_player.c.o' failed
| make[2]: *** [demos/apdu_player/CMakeFiles/apdu_player_demo.dir/apdu_player.c.o] Error 1
| CMakeFiles/Makefile2:1947: recipe for target 'demos/apdu_player/CMakeFiles/apdu_player_demo.dir/all' failed
| make[1]: *** [demos/apdu_player/CMakeFiles/apdu_player_demo.dir/all] Error 2
| Makefile:129: recipe for target 'all' failed
| make: *** [all] Error 2
| WARNING: exit code 1 from a shell command.

=================================================

please find the recipe and error log file attached and give me a suggestion

Labels (1)
0 Kudos
1 Solution
35 Views
NXP TechSupport
NXP TechSupport

Hello Pamakrishna,

There was no gcc version in the logs, but this most likely has to do with the version of gcc which seems to not support Wformat-security without Wformat.

Please remove -Wno-format in simw-top/demos/apdu_player/CMakeLists.txt:
change:
IF(CMAKE_COMPILER_IS_GNUCC)
ADD_DEFINITIONS("-Wno-unused-function -Wno-format")
ENDIF()
to:
IF(CMAKE_COMPILER_IS_GNUCC)
ADD_DEFINITIONS("-Wno-unused-function")
ENDIF()

Please kindly try it again and let me know if the problem is still there.

Hope that helps,

Have a great day,
Kan


-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!
- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
35 Views
Contributor I

Please find the logs here

0 Kudos
36 Views
NXP TechSupport
NXP TechSupport

Hello Pamakrishna,

There was no gcc version in the logs, but this most likely has to do with the version of gcc which seems to not support Wformat-security without Wformat.

Please remove -Wno-format in simw-top/demos/apdu_player/CMakeLists.txt:
change:
IF(CMAKE_COMPILER_IS_GNUCC)
ADD_DEFINITIONS("-Wno-unused-function -Wno-format")
ENDIF()
to:
IF(CMAKE_COMPILER_IS_GNUCC)
ADD_DEFINITIONS("-Wno-unused-function")
ENDIF()

Please kindly try it again and let me know if the problem is still there.

Hope that helps,

Have a great day,
Kan


-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!
- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

View solution in original post

0 Kudos