[S32K144][SCST] Hard Fault Test failure while checking a HFSR[FORCED] bit

cancel
Showing results for 
Search instead for 
Did you mean: 

[S32K144][SCST] Hard Fault Test failure while checking a HFSR[FORCED] bit

Jump to solution
72 Views
sunghou-kim
Contributor II

Hello, NXP team !

This is sungho.

I have an issue regarding using "core test solution(SCST)" for S32K144.

 

m4_scst_exception_hard_fault1 <= This test item not working fine so far.

 

On entry "m4_scst_ISR_dispatcher" , HFSR[FORCED]  is  set by illegal instruction. (plz see attached image)

sunghoukim_0-1626931846951.png

 

But soon as I proceed by one step(Trace32), It becomes clear....so test ends up with failure.(refer to an image below)

sunghoukim_1-1626931917887.png

sunghoukim_2-1626931991762.png

Would you mind giving me a hint for resolving this issue?

Thanks

Sungho

 

PS. I also tested it with demo app example(scst), but got failure with the same reason.

0 Kudos
1 Solution
55 Views
martinkaspar-r3
NXP Employee
NXP Employee

Hello,

this is expected behavior because the FORCED flag is tied down by the debugger. Unfortunately, this feature complicates debugging of M4 SCST Library. The only possibility for debugging is to set the breakpoint just after the HFSR register is read.

View solution in original post

0 Kudos
2 Replies
37 Views
sunghou-kim
Contributor II

Thanks, martingkaspar-r3

I checked it working fine without Debugging attached.

Many thanks,

sunghou

0 Kudos
56 Views
martinkaspar-r3
NXP Employee
NXP Employee

Hello,

this is expected behavior because the FORCED flag is tied down by the debugger. Unfortunately, this feature complicates debugging of M4 SCST Library. The only possibility for debugging is to set the breakpoint just after the HFSR register is read.

View solution in original post

0 Kudos