Debug on S32K144 with IAR and Multi-Link Universal

cancel
Showing results for 
Search instead for 
Did you mean: 

Debug on S32K144 with IAR and Multi-Link Universal

489 Views
takahiro_kataok
Contributor I

Hi Readers.

I have a trouble with debugging on S32K144.
Please anyone help me.

[IDE]
IAR embedded Workbench, ver8.11.2.13606

Option settings are
<Debugger> -> <setting> -> Driver is “PE Micro”
<Debugger> -> <download> -> check “verify” and “use Flash loader”

[Debugger]
PE Micro, Multi Link Universal, FW ver.1029
Interface pins between debugger and S32K144 are SWDIO, SWCLK, RESETB, VCC, GND.

[Phenomenon]
When I push “Download and debug”,
IDE outputs warning log “Target inconsistency detected in Memory range 0x00000004-0x000003F9”
and “Target inconsistency detected in Memory range0x00000411-0x0000E8DF”
I think that these means Flash was not updated.
But IDE starts to debug wiht old FW, and I can push “step in” or else.

What do I check first?

If I use another environment,
Such as IDE is Keil uVision5 , Debugger is ULINK2,
Flash update will be success.
So, I think Interface has no problems.

0 Kudos
3 Replies

342 Views
takahiro_kataok
Contributor I

Since the problem was solved, I will describe the contents.

The reason was that I was using CMSIS pack of S32K144.

Flash writing area is wrong when using CMSIS pack on IAR Embedded Workbench.

It was possible to write without problems if the driver software was expanded and writing was performed without using the CMSIS pack.

0 Kudos

342 Views
takahiro_kataok
Contributor I

Hi Diana

Thank you for reply.

I have checked memory range described in ddf file and icf file.

It seems not wrong but something is wrong maybe.

I don't use special placement, want to use it in default.

I think this problem is caused by dowmload tool,

so I will ask PE micro this problem.  

0 Kudos

342 Views
dianabatrlova
NXP TechSupport
NXP TechSupport

Hi,

Have you checked the memory ranges in your project?

You can use the S32 Design Studio plug in to create a project for IAR.

HOWTO: Export S32DS Project to IAR EW (S32K14x/S32K11x) 

Have you tried S32Design Studio for ARM v 2.2?

S32 Design Studio for ARM 2.2 – Windows/Linux

 There a basic application with the S32 SDK for use with IAR Embedded Workbench:

<SDK_PATH>\examples\S32K144\demo_apps\hello_world_iar.

However, I recommend contacting their support.

www.pemicro.com/support

https://www.iar.com/support/technical-support/ 

I hope it helps.

Best regards,

Diana

0 Kudos