Empty signal spaces being set on LIN Stack

cancel
Showing results for 
Search instead for 
Did you mean: 

Empty signal spaces being set on LIN Stack

Jump to solution
195 Views
joseponc
Contributor III

Hi. 

I have a question related to the autogenerated code after setting up my .ldf file using the SDK.

When I finished setting everything up, I noticed that the array that keeps track of the LIN signal values is initialized according to the configuration. However, bytes which belong to a message but do not have a signal assigned (empty message bytes) or bits within a byte that also don't have a signal assigned are given a "set" default value. For example, empty bytes are given 0xFF as default values and empty bits are set to be 1.

StackBitsQuestion.PNG

In the screenshot, signals values within the blue circle are examples of unwanted set bits or empty positions set as 0xFF

Is there a configuration that I could change to make this reset instead of set? (zeroes instead of ones) Or do I have to manually set those values?

0 Kudos
1 Solution
120 Views
hungnguyenphi
NXP Employee
NXP Employee

Hi,

Unfortunately, the SDK Linstack doesn't support the feature which you mention. But because these data do not belong any signal, I think that we don't need to care about it. So you will need to do it manually.

Best regards,

Hung

View solution in original post

0 Kudos
1 Reply
121 Views
hungnguyenphi
NXP Employee
NXP Employee

Hi,

Unfortunately, the SDK Linstack doesn't support the feature which you mention. But because these data do not belong any signal, I think that we don't need to care about it. So you will need to do it manually.

Best regards,

Hung

View solution in original post

0 Kudos