S32v234 Stereo camera demos problem

cancel
Showing results for 
Search instead for 
Did you mean: 

S32v234 Stereo camera demos problem

913 Views
giulioscalia
Contributor I

Hi,

We built a linux BSP (v18.0) using yocto, along with the meta-adas layer, but we are having problem running the provided demos.

Our system is a s32v234 sbc, using 2 Sony imx224 cameras.

In particular we are having problem with the demos isp_stereo_calib and isp_stereo_apexbm, here it is what happens:

stereo_cam.png

stereo_bm.png

We are sure that the cameras are both individually working (we tried switching them in both bus) and, moreover, we successfully ran the isp_sonyimx224_csi_dcu_cam_switch.

Does anyone have the same problem? Does anyone know what could cause this behaviour?

We tried also to investigate the provided isp graph to find it out, but without documentation we were not able to make it work. Is it possible to have such documentation?

Thanks in advance.

Labels (1)
0 Kudos
4 Replies

509 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

the camera has Master/Slave mode. For isp_stereo_calib demo you need to connect Master camera into MIPI-A  slot and Slave into MIPI-B. Here is Master/Slave settings: 

https://www.nxp.com/downloads/en/schematics/S32V-SONYCAM-SCH.pdf 

Here how the Master/Slave cam looks: 

imx224_master_slave.jpg

For slave you need to remove the right resistor and short the middle one. With this settings I can see clear images for isp_stereo_calib demo. 

The isp_stereo_apexbm demo - have still the very same result as you and no update from Vision team yet. 

Jiri 

0 Kudos

509 Views
giulioscalia
Contributor I

Hi Jiri,

Thanks for the support, after applying the hardware modification you suggested, the calibration is working correctly, but the apexbm demo show some lines in the output a little bit strange: here is the screenshot

pastedImage_1.png

My hand can be clearly seen but much of the output in not comprehensible (or at least to me), is it normal?

Thanks,

Giulio

0 Kudos

509 Views
kushalshah13
NXP Employee
NXP Employee

Hi giulioscalia‌,

The lines in the demo is due to incorrect working of remap function that this demo uses.

This issue is known and is fixed for next release of Vision SDK.

Thanks,

Kushal

0 Kudos

509 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

I can reproduce your issue with Linux BSP included in VSDK RTM_1.2.0_HF1. I'll contact Vision team. 

Jiri 

0 Kudos