S32DS Use P&E Multilink Universal for MPC5744P Devkit

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

S32DS Use P&E Multilink Universal for MPC5744P Devkit

1,647 Views
hesander
Contributor II

Hi,Master,PLEASE HELP!

Warning: Device is notdetected or may be censored. Please check connections or please enter password in GDB server parameters within debug configurations using the flag-uncensorpassword-n, then restart the debug ssession.

I was using a development board, the hardware should be fine.And the restart indicator on the development board flashes when debug is pressed.

pastedImage_2.png

pastedImage_3.png

0 Kudos
1 Reply

1,364 Views
stanish
NXP Employee
NXP Employee

Hi,

This dialog often may pop-up when there is a connection issue.

Could you try to program the board using OpenSDA interface (usb cable)?

If you connect USB Multilink Universal you should see both Multilink LEDs on (Blue and range).

Please check the ribbon cable orientation.

Also please check reset LED. If it is ON then probably a reset escalation has occurred (a code inside causes MCU reset - 10x reset = reset escallation).

The debugger might have difficulty to connect to MCU if it is in reset escalation mode. 

Therefore sometimes it helps if you power-up the board immediately after pressing debug button so the debugger initiates connection before reset escalation occurs.

You can use jumper J13 on MPC5744P Devkit board for this purpose :

1) Simply remove jumper - MCU is not powered

2) press Debug button and put the jumper back at its original position

3) after few attempts the debug connection should be established 

pastedImage_1.png

As a general suggestion I'd recommend re-installing up-to-date Pemicro Drivers:

pastedImage_2.png

and updating S32DS for Power: 

S32 Design Studio for Power Architecture v2.1 (Windows/Linux) released! 

https://community.nxp.com/docs/DOC-344218 

(it often includes an updated version of P&E plugin)

Hope it helps.

Stan

0 Kudos