S32DS Installation on Ubuntu14.04

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

S32DS Installation on Ubuntu14.04

Jump to solution
904 Views
stevecheng
Contributor I

Hi,

I got error while installing S32DS on ubuntu 14.04 which is running inside a Windows 10 virtualbox.

Looks like license issue, could you give me a license key and instruction on how to install it?

thanks,

Steve Cheng

Loading externalized properties


System's temporary directory = /tmp
RepositoryManager: Trying fallback repository location...
==== License service installation log start: ====

==== License service installation log end. ====
==== License activation log start: ====
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/nxp/s32ds/ext/rcp/license/cli/CLI : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: com.nxp.s32ds.ext.rcp.license.cli.CLI. Program will exit.

==== License activation log end. ====
==== License list start: ====
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/nxp/s32ds/ext/rcp/license/cli/CLI : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Could not find the main class: com.nxp.s32ds.ext.rcp.license.cli.CLI. Program will exit.

==== License list end. ====
XMLScriptWriter: No Installation Objects were skipped
Did not match to message method
8. final log file name=/home/scheng/NXP/S32DS_Power_v2017.R1/_S32 Design Studio for Power Architecture Version 2017.R1_installation/Logs/S32_Design_Studio_for_Power_Architecture_Version_2017.R1_Install_03_11_2019_13_32_07.log
====================STDOUT ENTRIES==================

0 Kudos
1 Solution
728 Views
alexeyshuginin
NXP Employee
NXP Employee

Good afternoon Steve,

Please install Java 1.8, see: software installation - Java JRE 8 install - Ask Ubuntu 

The following error in the log means Java 1.7 is used, default for Ubuntu 14: Unsupported major.minor version 51.0

See also class versions description:

https://stackoverflow.com/questions/10382929/how-to-fix-java-lang-unsupportedclassversionerror-unsup...

View solution in original post

0 Kudos
2 Replies
728 Views
creigelde
Contributor I

Unsupported major.minor version error is because of Java version mismatch. It happens when you compile your projects on higher version of java(e.g. jdk 1.8) and then run it on a lower version (e.g. jdk 1.7). Depending on your situation, you have two ways to resolve this error: compile your code for an earlier version of Java, or run your code on a newer Java version. Sometimes you may have more than one version of Java SDK installed in your machine. Make sure the application you are running is pointing to the right or highest version available . It is better you need to install both JRE/JDK with the same version.

0 Kudos
729 Views
alexeyshuginin
NXP Employee
NXP Employee

Good afternoon Steve,

Please install Java 1.8, see: software installation - Java JRE 8 install - Ask Ubuntu 

The following error in the log means Java 1.7 is used, default for Ubuntu 14: Unsupported major.minor version 51.0

See also class versions description:

https://stackoverflow.com/questions/10382929/how-to-fix-java-lang-unsupportedclassversionerror-unsup...

0 Kudos