Peripheral configuration issue

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Peripheral configuration issue

389 Views
MohitManvar
Contributor III

Hello Team,

I started using S32 Design studio from few days.

currently I am working on S32K142 microcontroller for sound application.

When I try to configure any peripheral from Peripheral Option , It is showing that Peripheral not present in toolchain project. If I select All available component then it is giving below warning.

MohitManvar_0-1685082768533.png

Below are some details of project.

MohitManvar_1-1685082861524.png

 

Please help me with explaining what to do in steps.

 

Thanks!

0 Kudos
5 Replies

379 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi MohitManvar,

According to the "6.3 Compiler and IDE versions" of S32SDK_for_S32K1xx_RTM_4.0.1_ReleaseNotes.pdf:

 GreenHills compiler v. 2017.1.4
 IAR compiler v. 8.11.2
GCC compiler for ARM v. 6.3.1 20170509
 Wind River Diab Compiler v5.9.6.2
 ARM Compiler 6.6.1 Long Term Maintenance
S32 Design Studio 3.3 IDE

Do not use S32DS v3.5, please use S32DS v3.4+S32K1 SDK RTM4.0.3.

Sorry for the inconvenience we bring you!

Best Regards,
Robin
-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

363 Views
MohitManvar
Contributor III

Hello,

I tried with installing S32DS 3.4 version as mentioned in your answer but Still I'm facing same issue.

0 Kudos

340 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Please select NXP GCC 6.3 for Arm 32-bit Bare-Metal Toolchain when create S32DS Application Project.

Create new S32DS Application Project.pngSelect SDK.jpg

After you double-click the component you want to add, this warning will disappear.

Select configuration component.jpg

0 Kudos

327 Views
MohitManvar
Contributor III

Hello Robin,

I tried same as your given steps but still having same warning.

MohitManvar_1-1685449230405.png

 

please provide solution ASAP.

 

Thanks!

Tags (1)
0 Kudos

283 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Have you tried S32DS v3.4+S32K1 SDK RTM4.0.3? It looks like your project is still using the old S32K1 SDK RTM4.0.1

MohitManvar_1-1685449230405 (1).png

Best Regards,
Robin

0 Kudos