PEMicro which version supporting S32K358

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PEMicro which version supporting S32K358

Jump to solution
534 Views
LeoZ
Contributor III

When I use PEMicro to link to my S3258 board, I got bellow issue "This hardware interface is an older model and does not support this device"

* does this mean my PEMicro version is too low?

* my PEMircro version is shown as bellow, does the 'Rev A' not support S32K358 and I should purchase a new version, and which version ?

old pe.jpgpe_ver.jpg

0 Kudos
1 Solution
513 Views
Mehul_Patel_NXP
NXP Employee
NXP Employee

Hi, @LeoZ , 

 

The PE multilink debugger you are using does not support S32K258 series. 

 

You will require to use PEMicro Multilink FX. 

 

Please check PE Micro website for more information for supported version, and hardware series. 

https://www.pemicro.com/products/product_viewDetails.cfm?product_id=15320180&productTab=5046

https://www.pemicro.com/arm/device_support/NXP_Automotive/index.cfm

 

 

Thank you. Best regards. 

- Mehul Patel 

 

 

View solution in original post

0 Kudos
2 Replies
514 Views
Mehul_Patel_NXP
NXP Employee
NXP Employee

Hi, @LeoZ , 

 

The PE multilink debugger you are using does not support S32K258 series. 

 

You will require to use PEMicro Multilink FX. 

 

Please check PE Micro website for more information for supported version, and hardware series. 

https://www.pemicro.com/products/product_viewDetails.cfm?product_id=15320180&productTab=5046

https://www.pemicro.com/arm/device_support/NXP_Automotive/index.cfm

 

 

Thank you. Best regards. 

- Mehul Patel 

 

 

0 Kudos
489 Views
LeoZ
Contributor III
I purchased Multilink Rev.E, which solved this problem
0 Kudos