I can not program S32K144 EVB

cancel
Showing results for 
Search instead for 
Did you mean: 

I can not program S32K144 EVB

858 Views
ebookkankan
Contributor II

 Dear:

       When I use the board S32K144 EVB, the reset light is always on after connecting the USB cable. The program cannot be written into the board by "S32 Design Studio".  I want to know what caused this and how can it be fixed. Please help me.Thank you very much.

            wangzhe

20200422130512.jpg

OT0RCKPOQ1GDWG)KM7@C@SP.jpg

PCO{TXEKG9.jpg

54.jpg

0 Kudos
6 Replies

730 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi wang zhe,

Please download the schematic of the S32K144EVB Evaluation Board, then check the connection of J107.
You should notice the version of your own board, you can find the version at the bottom side.
Make sure the power of MCU is from P5V_SDA_PSW instead of P5V_SBC.

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

730 Views
ebookkankan
Contributor II

Thank you for your answer, but the problem is still not solved.

0 Kudos

730 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Would you please let me know the version of your S32K144EVB?(The schematic of several version for S32K144EVB are different.)

My board info is SCH-29248 REV B1, I connect Pin2 and Pin3 of J107. I am able to debug it when plug USB cable at J7.

J107 S32K144EVB RevB.png

Please select the Emgerency Kinetis Device Recovery by Full Chip Erase.

Emgerency Kinetis Device Recovery by Full Chip Erase.png

If this doesn't work, then please try to use the P&E recovery utility mentioned in Bricking and Recovering FRDM-KL25Z Boards: Reset, SWD Clock and Low Power. )

 

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

698 Views
parveez
Contributor I

Hi @Robin_Shen ,

 

I had similar issues but just D2 LED is ON in my case.

The solution didn't work for me and  do not have access to the page you shared for P&E recovery utility. Can you please help me find a solution?

0 Kudos

680 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

I have modify the link. You should be able to access it now.

0 Kudos

611 Views
rparveez
Contributor II

Hi @Robin_Shen 

 

I tried all this solutions and none of them worked for me. 

I had got another s32k144 board but even that is in same state now. I had just connected MC33772B evaluation board to it. 

I am not sure what the issue is. Because something has gone wrong on both the boards. Is there any other way to fix this? The U11 chip on both the boards eats up when connected to power supply.

On one of the board, I am not able to powerup using 12V. Even though J107 pins 1-2 connected. 

Thanks,

Rubeena

 

0 Kudos