S32 Design Studio for Power v1.2 (Windows/Linux) released!

cancel
Showing results for 
Search instead for 
Did you mean: 

S32 Design Studio for Power v1.2 (Windows/Linux) released!

S32 Design Studio for Power v1.2 (Windows/Linux) released!

 

 

 

 pastedImage_14.png

Product Release Announcement

Automotive Microcontrollers and Processors

S32 Design Studio for Power v1.2

 

 

 

 

 

 

S32 Design Studio for Power v1.2 (Windows/Linux) has been released. This is a complete installer which does not require any previous version to be installed.

To download the installer please visit download section: www.nxp.com/s32ds

pastedImage_29.png

What is new?

New devices:

• MPC5632M, MPC5633M, MPC5634M
• MPC5642A
• MPC5674F
• MPC5673K, MPC5674K, MPC5675K
• S32R372

New features:

• Compiler update – see details in compiler release notes attached below
• View for the Special Purpose Registers added
• Improvements for Peripherals Register view
• Added support for Semihosting/Debug console for single core devices
• RESET functionality added, the hardware reset2 is executed for main/boot core and individual core reset for secondary cores.
• Improvements for SPT diagram to display instruction labels and key parameters
• SDK mechanism improvements to support SDK per build configuration
• FreeMaster Serial Communication driver 2.0 integrated
• iSystem debugger support added to New Project Wizard
• SPT assembler update
• Updated P&E debug plugins and drivers to the latest and greatest versions

Note:
The plugins to support GreenHills, IAR, iSystem, Lauterbach are not included and have to be installed from corresponding update site or installation.

S32DS release notes are available here.

GCC Build tools release notes are here.

 

Installation Notes

The installer requires NEW Activation ID to be entered during the installation. You should receive an email including the Activation ID after starting the download process e.g:

pastedImage_1.png

 

 

Attachments
Comments

GCC source code for the provided binaries?

I'm lazy, so before going to v1.2 full install, I'd like to be sure...

Upgrading from v1.1 is impossible ?

Hi,

I'm having problems flashing MPC5748G using V1.2...

Example still working in V1.1..

Regards

Voila_Capture 2017-06-22_02-14-05_am.png

Hi Jed,

Thanks for the notification!

GCC Source Code package is available in the download section now.

pastedImage_1.png

Stan

Ludwig,

I'm having similar troubles getting things flashed with 1.2. Both in the Eclipse environment and in my own command line flashing utility [GitHub - jed-frey/opensda_flasher].

I believe it's an issue stemming from the new version of the PEMicro GDB server which has been upgraded. I didn't want to say anything until I had proper time to investigate but could you try replacing the PEMicro executable with the older one from 1.1? 

It's here:

eclipse\plugins\com.pemicro.debug.gdbjtag.ppc_xxxxxxx\win32\pegdbserver_power_console.exe

I'm away from my bench this week, but from what I remember there were additional init steps in the newer version which I think is causing the GDB client to timeout and fail.

Other things that I'd like to, but haven't, tried are changing the speed or having it not reset the micro when it attaches.

I tried your suggestion and running into strange issues. For one, IVOR2_Vector() is a dead end it seems, stepping is not possible. pe/gdb also complains about a password setting, never seen before and not working from this point. I re-installed the old drivers from ./Drivers/PEDrivers_install.exe but no success. At 98%, programming of Flash/Ram starts, which was not the case before.
Any ideas? Enjoy weekend.

-L

It was worth a shot.

The latest version of the .MAC(?) file has multiple extra commands when doing an init:

Old version on the left, new version on the right:

So I went through and diffed the other files in the gdi\P&E folder:

The .add file changes the FLASHALG and programming DLL.

And additionally adds TARGET_XML_CORE# .xml files:

The .PCP file changes a few things during programming. I'm wondering if it's the double_buffering.

I got DLL Exporter to show a few functions.

I may try to see if I can make a Python wrapper for it to flash directly skipping the GDB server part.

I commend NXP for finally releasing an inexpensive automotive grade micro-devboard. However it seems like legal or the 'old' way of thinking got in the way with implementation.  Those that deal with e200 daily know its value, but for a novice university student the provided software toolchain lags far behind Arduino and STMicro's devkits. 

Each of the installs is completely standalone and self contained (right down to the Java binaries). You should have no problem installing them along side each other.

1.1 installs into C:\Freescale\S32_Power_v1.1

1.2 installs into C:\NXP\S32DS_Power_v1.2

You can even set them up with different workspaces.

I got some more time to mess around with it. I definitely think it's something with the new version of the GDB server and not the driver.

I had the old and new versions side by side and continually got errors like this with the new version:

The old version seemingly worked fine.

Additionally I cannot find any documentation on the GDB server's commands such as what 'preserve' does or how the 'selectcore' and 'multimode' monitor commands work.  Google doesn't turn up anything since this is the only software tools where the commands seem to be used.

The OpenSDA chip has its own debugger. I'm wondering what the difficulty would be in getting rid of the PE Micro software and making an opensourced version. While I have had other issues with my Arduino and STMicro Discovery boards nothing on this level when doing something as simple as flashing.

Hi again after some weeks,

I am still stuck and it is frustrating.

This is a newly installed Windows 10 workstation, very powerful, with freshly installed S32DSv1.2 + Updates

I am not sure how to proceed: Use v1.1 or try hacking PE.

jfrey‌: How is your progress, the wrapper, or just a working workaround to this? Is this somehow limited to DEVKIT-MPC5748G?

2017-08-27 19_23_59-C_C++ - hello_world_mpc5748g_Sources_main.c - S32 Design Studio for Power Archit.png

2017-08-27 19_29_24-.png

Update to myself and all:

It seems working now, after I flashed the firmware with this file DEBUG-OPENSDA-E200_Pemicro_v110.SDA as mentioned in Failed to debug MPC5748G at 98% for S32DS v1.2 (Post starting from 16/08/2017 shows how current this issue is)

I have not validated stability or such, but assume this will work now.

Regards

Version history
Revision #:
1 of 1
Last update:
‎06-19-2017 08:40 AM
Updated by: