Error in flex-builder command

cancel
Showing results for 
Search instead for 
Did you mean: 

Error in flex-builder command

1,399 Views
anesarkar
Contributor II

Hi,

   I am getting the following error in flex-builder after executing following command ->

flex-builder -i merge-component -a arm64

INSTRUCTION: merge-component
DESTARCH: arm64
[sudo] password for anish:
/sbin/ldconfig.real: /usr/local/lib/libOpenVG.so is not a symbolic link

/home/anish/Desktop/flexbuild/tools/flex-builder: line 1423: cd: /home/anish/Desktop/flexbuild/packages/linux/linux: No such file or directory

Can someone tell me how to handle this problem? I am trying to build ubuntu image on sd card for LS1028ARDB.

9 Replies

710 Views
anesarkar
Contributor II

I still get the error of

/sbin/ldconfig.real: /usr/local/lib/libOpenVG.so is not a symbolic link

Any solution for this?

0 Kudos

710 Views
yipingwang
NXP TechSupport
NXP TechSupport

If there is problem to execute command "flex-builder -i merge-component -a arm64" to merge Freescale special apps and Kernel modules into rootfs filesystem, you could copy app_components_LS_arm64.tgz  and lib_modules_LS_arm64_<version>.tgz to the target board and deploy them to rootfs directly.

After executing "flex-builder -i mkrfs -a arm64", you will get Ubuntu rootfs filesystem, after deploy it to SD or SATA and boot up the system, please copy app_components_LS_arm64.tgz and lib_modules_LS_arm64_<version>.tgz to the target board to do the following operations.

$ tar -xzvf app_components_LS_arm64.tgz

$ cp -r components_LS_arm64/*  /

$ tar -xzvf lib_modules_LS_arm64_4.19.26.tgz

$ cp -r 4.19.26/*  /lib/modules/<version>/

Thanks,

Yiping

710 Views
yyu2
Contributor III

Hi Yiping,

Regarding "/sbin/ldconfig.real: /usr/local/lib/libOpenVG.so is not a symbolic link", is there any workaround for it now?

0 Kudos

710 Views
Pavel
NXP TechSupport
NXP TechSupport

Use the following command sequence:

$ flex-builder -i mkrfs -a arm64
$ tar xvzf app_components_LS_arm64.tgz -C build/apps
$ sudo tar xvzf lib_modules_LS_arm64_4.14.104.tgz -C build/rfs/rootfs_lsdk_19.03_LS_arm64/lib/modules
$ sudo tar xvzf lib_modules_LS_arm64_4.19.26.tgz -C build/rfs/rootfs_lsdk_19.03_LS_arm64/lib/modules

flex-builder -c linux -a arm64

flex-builder -i merge-component -a arm64

Have a great day,
Pavel Chubakov

-------------------------------------------------------------------------------
Note:

This thread is continued as a private discussion with the submitter,
NXP support is not following the thread anymore.
-------------------------------------------------------------------------------

0 Kudos

710 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Anish Nesarkar ,

Please execute "flex-builder -i mkrfs -a arm64" first, then execute "flex-builder -i merge-component -a arm64".

 

Please refer to the following procedure.

1. Generate Ubuntu arm64 userland

$ flex-builder -i mkrfs -a arm64

 

2. Extract app components or kernel modules

$ tar xvzf app_components_LS_arm64.tgz -C build/apps

$ sudo tar xvzf lib_modules_LS_arm64_<kernel_version>.tgz -C build/rfs/rootfs_ubuntu_bionic_LS_arm64/lib/modules

 

3. Merge all components packages and kernel modules into target userland and compress ubuntu arm64 rootfs as .tgz tarball

$ flex-builder -i merge-component -a arm64
$ flex-builder -i compressrfs -a arm64

Thanks,

Yiping

710 Views
nxf54443
NXP Employee
NXP Employee

Hi Yiping,

I am using Linux 18.03 (docker container for 18.03 on 16.04 host) and am working on LSDK 19.03.

I have executed the exact same commands as you have mentioned in the post here.

The second last command i.e. "$ flex-builder -i merge-component -a arm64" worked perfectly fine,


but the last one i.e. "$ flex-builder -i compressrfs -a arm64" shows the following error,
INSTRUCTION: compressrfs
DESTARCH: arm64
invalid instruction: compressrfs


Can you explain the reason behind this error and the way to fix it ?

710 Views
sameer_chouksey
Contributor II

Hello tarunchawla127@gmail.com,

I am facing exact same issue. Did you find some solution to this??

Regards,

Sameer

0 Kudos

710 Views
940849422
Contributor I

Hello  

      It's the same problem for me. How did you solve it?

                                                                  Thank you

0 Kudos

710 Views
anesarkar
Contributor II

Hi, 

     I followed all those steps. I did get the two .tgz files. I am getting error at $ flex-builder -i merge-component -a arm64 but not at $ flex-builder -i compressrfs -a arm64.

So, I do get the final compressed file. But, I don't know if the final compressed file is correct because this command "$ flex-builder -i merge-component -a arm64" failed.

Later, when I try to load the image on board using usb and flex-installer " boot partition and ubuntu rootfs" using sd card, I get the following error

pastedImage_1.png

0 Kudos