FlexGUI for FS85 / FS84 Evaluation Tools: ".bat" file does not do anything

cancel
Showing results for 
Search instead for 
Did you mean: 

FlexGUI for FS85 / FS84 Evaluation Tools: ".bat" file does not do anything

Jump to solution
691 Views
BL_
Contributor III

Hi,

we want to use the KITFS85SKTEVM evaluation board for burning the FS8530 OTP. As stated in UM11183 document, a FlexGUI is required. I have downloaded and extracted the FlexGUI software.

The problem is that: when running the "flexgui-app-spm-fs8xx0-0.9.5\bin\flexgui-app-spm.bat", there's nothing happens.

What could be the problem for this and how to fix it?

Thanks

BL

Labels (1)
Tags (2)
0 Kudos
1 Solution
674 Views
JozefKozon
NXP TechSupport
NXP TechSupport

Hi BL,

thank you for confirmation. Please follow steps described by a FlexGUI developer below and see if it helps.

DESCRIPTION

FlexGUI launch script preferably uses JAVA_HOME to find executable called "javaw". If JAVA_HOME is not defined, script still looks for "javaw" in system variable called "Path". Since it is valid to have several instances of Java on single OS, it is not guaranteed that entry in "Path" leads to desired Java instance, thus it is better to explicitly define JAVA_HOME instead. 

Please follow steps below in order to make it work.

Setting the JAVA_HOME Variable in Windows - Atlassian Documentation 

anon-696f160ab2cb, as a path for JAVA_HOME use "<C:\Program Files\Java\jre1.8.0_211>".

With Best Regards,

Jozef

View solution in original post

0 Kudos
4 Replies
686 Views
JozefKozon
NXP TechSupport
NXP TechSupport

Hi Bien,

please confirm, that you have downloaded the FlexGUI from this link: https://www.nxp.com/design/analog-expert-software-and-tools/flexgui-software-tool-for-evaluation-of-...

JozefKozon_0-1644322744741.png

Please download and install Java 8 distribution version on your computer according to OS you are using. 

https://www.oracle.com/java/technologies/downloads/#java8-linux

JozefKozon_1-1644323057838.png

Please let me know, if it solved your issue.

With Best Regards,

Jozef

0 Kudos
677 Views
BL_
Contributor III

Hi Jozef,

Comments to the questions

However this does not solve the problem. When running "flexgui-app-spm.bat", still there nothing happens (the CMD windows poped up for a short moment and then gone).

 

Regards,

BL

0 Kudos
675 Views
JozefKozon
NXP TechSupport
NXP TechSupport

Hi BL,

thank you for confirmation. Please follow steps described by a FlexGUI developer below and see if it helps.

DESCRIPTION

FlexGUI launch script preferably uses JAVA_HOME to find executable called "javaw". If JAVA_HOME is not defined, script still looks for "javaw" in system variable called "Path". Since it is valid to have several instances of Java on single OS, it is not guaranteed that entry in "Path" leads to desired Java instance, thus it is better to explicitly define JAVA_HOME instead. 

Please follow steps below in order to make it work.

Setting the JAVA_HOME Variable in Windows - Atlassian Documentation 

anon-696f160ab2cb, as a path for JAVA_HOME use "<C:\Program Files\Java\jre1.8.0_211>".

With Best Regards,

Jozef

0 Kudos
662 Views
BL_
Contributor III

Hi Jozef,

Setting the JAVA_HOME variable solved the problem.

Thanks very much.

BL

0 Kudos