S32K3X4EVB-T172 with MBD

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

S32K3X4EVB-T172 with MBD

1,888 Views
mohamed-moustafa
Contributor I

any code generated and deplyed to the board cause reset led flickering "sequential reset"
I exported the code to debug it found that this generated function casue to jump to reset handler

"board_init();"

mohamedmoustafa_0-1682376044604.png

 

Labels (1)
0 Kudos
Reply
10 Replies

1,843 Views
mohamed-moustafa
Contributor I

After deploying any model "as example blink led matlab model" on the board
its reset led keeps blinking "continuous reset as indication for fault which cause to reset the controller"
I also tried the supported examples but no one for the bord S32K3X4EVB-T172 only for Q172 "has the same problem"

0 Kudos
Reply

1,832 Views
georgevictor
NXP Employee
NXP Employee

Hi, @mohamed-moustafa,

It appears that your board keeps resetting, a problem that might be brought on by the incorrect initialization of the SBC. To prevent an incorrect SBC initialization, after connecting your 12V power supply to the board, please turn it on using the power switch, or, run a power cycle.

Please let me know if this helps.

Have a nice day,

Victor

 

0 Kudos
Reply

1,818 Views
mohamed-moustafa
Contributor I

unfortunately no difference

"I am start with power switch off ,connect usb then switch it on same reseting case"

0 Kudos
Reply

1,795 Views
georgevictor
NXP Employee
NXP Employee

Hi, @mohamed-moustafa,

I am sorry that the initial proposal wasn't a quick fix.

I see that you tried to debug the application in S32DS after exporting the code. I'll ask you a few questions that might help us figure out how to resolve your problem as follows:

1. Each peripheral used by the application is initialized inside the board_init() function. Could you tell us which line in the board_init() function results in the jump to the reset handler?

2. Could you send us a photo of your board?

3. Have you used any of the other examples we provided to check the board functionality?


Please try to download other applications onto the board to see if the issue persists. The majority of our examples delivered with the toolbox are configured for the S32K344-Q257 processor, but, as stated in the readme file of each example, they can easily be used for multiple hardware parts. The S32K3X4EVB-T172 board that you are using has the same processor (S32K344-Q172 Hardware Part selection) as the S32K3X4EVB-Q172 board used to validated our examples. Therefore, when you build an application, make sure the Hardware Part is set to S32K344-Q172.

Cheers,

Victor

 

0 Kudos
Reply

1,754 Views
mohamed-moustafa
Contributor I

If it is possibe to send me a simulink example"blink led" folder to run and test without any editings needed 
on MATLAB 2021a
this will be more efficient
Thanks

0 Kudos
Reply

1,755 Views
mohamed-moustafa
Contributor I

All supported examples cause the same problem 
After debugging I think the main problem related to PMC
I cannot detect the actual line casues the reset but it is entire this function

mohamedmoustafa_0-1683028958591.png

 

 

0 Kudos
Reply

1,751 Views
mohamed-moustafa
Contributor I

mohamedmoustafa_0-1683030618722.png

actually what happening is when get oy from Mcu_Init and try to step into Mcu_InitClock 
it is go to reset handler 
Cannot determine the main cause

0 Kudos
Reply

1,367 Views
georgevictor
NXP Employee
NXP Employee

Hi, @mohamed-moustafa ,

I hope this finds you well.
I have managed to reproduce the sequential reset of the S32K3X4EVB-T172 on my side.
As a quick fix until we will find what is the root cause that generates the reset issue I advise you to verify the J31 jumper that is found next to the MCU on the evaluation board and set it to 2-3. The 2-3 configuration provides a power supply for the MCU V15 input from the VDD_HV_B supply. As default, the jumper is configured on 1-2 and the MCU V15 input is powered by the FS26_VCORE supply of the FS26 SBC. For this particular board, the jumper that is set to 1-2 causes the MCU to reset for some applications.

Hope this helps until we will finish an in-depth investigation for this issue.

Cheers,

Victor

 

0 Kudos
Reply

510 Views
SParihar
Contributor III

Was facing the same problem, board was resetting after deploying the program. But after changing the J31 position, the code is downloading in the board properly.

0 Kudos
Reply

1,887 Views
mohamed-moustafa
Contributor I

I am not able to detect the problem and how to fix

 

0 Kudos
Reply