BAM update Problem (CAN)

cancel
Showing results for 
Search instead for 
Did you mean: 

BAM update Problem (CAN)

Jump to solution
1,112 Views
youngguekim
Contributor III


Hi. I am using MPC5644A

 

I want to update a Firmware using BAM(eSCI).

 

But When i am receiving CAN_A message continually, I can;t update

 

For example, I receive CAN message like Figure. 1

There is no BAM echo message (0xFEEDFACE)

and When CAN_L, CAN_H pin are short, BAM works well

 

I can't understand that CAN_A message'ID I recieved is not 0x00, 0x01, 0x02, 0x03, 0x11, 0x12, 0x13

Help me please

 

Figure 1.

 

155480_155480.pngpastedImage_1.png

Labels (1)
0 Kudos
1 Solution
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Well, then it makes sense. There shouldn't be any traffic on CAN_A because (copied from reference manual):

pastedImage_0.png

Lukas

View solution in original post

0 Kudos
13 Replies
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Hi,

just a quick question - do you use fixed baud rate or baud rate detection?

Regards,

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

Hi.

I am using baud rate detection (115200bps)

0 Kudos
759 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Well, then it makes sense. There shouldn't be any traffic on CAN_A because (copied from reference manual):

pastedImage_0.png

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

Thank you.

if I use Fixed Baud rate(eSCI) for Download. Can be any traffic On CAN_A ?

I can't remove CAN_A message from other ECU

0 Kudos
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Yes, but there can't appear a message with 0x11 ID:

pastedImage_0.png

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

Thank you very much

I have only 1 Question.

when I use Fixed Baud rate (9600bps, crystal frequency : 8MHz),  I can't receive echo message(0xCAFEBEEF)


do you know what is problem??

1. Fixed Baud rate

pastedImage_5.png

2. Baud rate Detection (Nomal)

pastedImage_4.png

0 Kudos
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Is a delay between characters long enough? We can't send next character to device until BAM finishes transmission of echo character. If the baud rate is 9600 bps, 10 bits (start bit + 8 data bits + stop bit) are transmitted in 1.04ms. If we add some time for software overhead, the delay between characters should be about 1.1ms or 1.2ms, at least. Could you check that?

It doesn't explain why it works when baud rate detection is used but I can't see other reason.

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

Delay between characters is long enough (above 0.5s)

it's better to use Detection mode.

Thank you for your help. Lukas Zadrapa

1. Fixed

pastedImage_1.png

2. Detection

pastedImage_0.png

0 Kudos
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

I did quick test on my board and it works as expected:

pastedImage_0.png

Once all data are sent, the BAM starts execution of downloaded program and stops sending of echo characters (0xAA character is used just for test).

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

Thank you.

you did a test in fixed Baud rate and Your Clock circuit is same as Picture(XTAL : 8MHz)?

pastedImage_0.png

0 Kudos
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Yes, I have 8MHz crystal.

Have you pulled EVTO pin up? You can use 5-10kohm resistor.

I tried to pull it down for test purposes and I can see that BAM returns only FEEDFACE in this case. So, this could be the reason.

pastedImage_0.png

Lukas

0 Kudos
758 Views
youngguekim
Contributor III

when I use Fixed mode, EVTO pin -> OPEN

when I use Detection mode, EVTO pin -> Short

you mean, When I use Fixed mode, I have pulled EVTO pin up (5~10kohm)?

I will try..

0 Kudos
758 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

EVTO is not pulled up internally:

pastedImage_0.png

So, you have to pulled it up by external resistor...

Lukas

0 Kudos