Why did printf() stop working?

cancel
Showing results for 
Search instead for 
Did you mean: 

Why did printf() stop working?

464 Views
mbra16
Contributor II

Hello,

I'm developing some software for the LPC804. In that regard I use MCUXpresso v11. 

Yesturday I was working on my project, and printf() was doing what it's supposed to without a problem. After work I saved, closed, and turned off my computer. Today when I wanted to continue working, printf() did not show up in the console. 

I tried making a new project and run it to see if it was some configuration in my current project that I messed up. To my surprise, it wasn't. The printf("hello world"); did not work in the new project either.

I can confirm I have selected Semihosting when making the project, and that the console writes "Awaiting telnet connection to port 3330 ..." when I initiate the debugging.

Is there anything obvious I'm missing? 

Labels (1)
Tags (2)
0 Kudos
3 Replies

267 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hi Martin,

I will suggest to check the following post. Here explain a similar problem. 

Best Regards,

Alexis Andalon

267 Views
mbra16
Contributor II

Thanks. While debugging configurations I found that the SDK Debug Console was set to UART. When I put it back to Semihost, it worked again. I wonder how it got changed in the first place, but my problem is resolved for now.

0 Kudos

267 Views
Alexis_A
NXP TechSupport
NXP TechSupport

Hi Martin,

I'm glad that you could solve your issue and thanks for sharing your solution.

Best Regards,
Alexis Andalon

0 Kudos