Error in final launch sequence No debugger path for breakpoint

cancel
Showing results for 
Search instead for 
Did you mean: 

Error in final launch sequence No debugger path for breakpoint

Jump to solution
580 Views
jren68
Contributor III

I am using MCUXpresso and ALL of my previously working projects suddenly are having this error upon clicking 'debug'

(build is still fine, I don't remember messing up any configuration)

pastedImage_1.png

So far I've tried

disconnect USB + restart MCUXpresso

ISP the board

restart laptop

uninstall and reinstall MCUXpresso

and this error still persists.

Any advice on how to fix it?

Labels (1)
1 Solution
380 Views
lpcxpresso_supp
NXP Employee
NXP Employee

It sounds like there’s a breakpoint entry for a file that’s not in any project under debug. You can look through the break list to see if this is the case, and delete the entry, or entries, or remove all breaks and add back what you need. If that doesn’t work, create a new workspace to import your projects into.

Thanks and regards,

MCUXpresso Support 

View solution in original post

1 Reply
381 Views
lpcxpresso_supp
NXP Employee
NXP Employee

It sounds like there’s a breakpoint entry for a file that’s not in any project under debug. You can look through the break list to see if this is the case, and delete the entry, or entries, or remove all breaks and add back what you need. If that doesn’t work, create a new workspace to import your projects into.

Thanks and regards,

MCUXpresso Support 

View solution in original post