LPC1758 : Cannot halt processor

cancel
Showing results for 
Search instead for 
Did you mean: 

LPC1758 : Cannot halt processor

90 Views
Contributor I

Hi, 

HOW TO RESET THE LPC1758 controller and take it out from this mode???

Using LPC Link with custom LPC1758 board. Using Program Flash option sent a BIN file to blank Board. (New board , never programmed before; first can not connect msg come).

After successfully flashing the BIN file. Now the controller is hung up. Tried to use debugger but msg comes;

Ed:03: Failed on chip setup: Ep(04). Cannot halt processor.

--------------------

Ni: LPCXpresso RedlinkMulti Driver v8.2 (Sep 5 2016 10:12:38 - crt_emu_cm_redlink.exe build 725)
Pc: ( 0) Reading remote configuration
Nc: Found chip XML file in C:/Working/hw-fw/PCBS/EIO_Controller/from Seb/eioc/EIOC_NoRTOS/Debug/LPC1758.xml
Pc: ( 5) Remote configuration complete
Nc: Probe Firmware: LPC-Link Probe v1.3 (NXP - LPC-Link)
Nc: Serial Number: WIN64HS12
Nc: VID:PID: 1FC9:0009
Nc: USB Path:
Pc: ( 30) Emulator Connected
Xw:
Wc: Cannot halt processor
Wc: Cannot halt processor
Pc: ( 40) No Halt
Pc: ( 50) CPU ID
Nc: Emu(0): Connected&Reset. DpID: 2BA01477. CpuID: 410FC230. Info: <None>
Nc: Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Wc: Cannot halt processor
Ed:03: Failed on chip setup: Ep(04). Cannot halt processor.
Pc: ( 65) Chip Setup Complete

------------------------------------

BIN file is good works good on previous version board. 

0 Kudos
3 Replies

11 Views
Senior Contributor III
0 Kudos

11 Views
Contributor I

Yes, Thanks. Controller came out of stuck state after using ISP pin and Reset pin, low state.

Now not able to connect;

shows

Ed:02: Failed on connect: Ee(36). Could not connect to core.

what are the possible reasons for this? any document available?

Ni: LPCXpresso RedlinkMulti Driver v8.2 (Sep 5 2016 10:12:38 - crt_emu_cm_redlink.exe build 725)
Pc: ( 0) Reading remote configuration
Nc: Found chip XML file in C:/Working/hw-fw/PCBS/EIO_Controller/from Seb/eioc/EIOC_NoRTOS/Debug/LPC1758.xml
Pc: ( 5) Remote configuration complete
Nc: connecting to core 0 with handle 0x0 (using server PID -1) gave rc 'Ee(36). Could not connect to core.'
Nc: connecting to core 0 with handle 0x0 (using server PID -1) gave rc 'Ee(36). Could not connect to core.'
Nc: connecting to core 0 with handle 0x0 (using server PID -1) gave rc 'Ee(36). Could not connect to core.'
Nc: probe unbooted? no core 0?
Ed:02: Failed on connect: Ee(36). Could not connect to core.
Et:31: No connection to emulator device
Pc: (100) Target Connection Failed

0 Kudos

11 Views
Senior Contributor III

Sounds like a problem with your board. See https://community.nxp.com/thread/388998 

0 Kudos